diff mbox series

[1/1] package/jack2: add host-pkgconf dependency

Message ID 20220812205623.175869-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/jack2: add host-pkgconf dependency | expand

Commit Message

Fabrice Fontaine Aug. 12, 2022, 8:56 p.m. UTC
Fix the following build failure:

Checking for program 'pkg-config'        : not found
The above check failed, but the checkee is required for --alsa.

Fixes:
 - http://autobuild.buildroot.org/results/cbdc251980f5571f75281202ebffc04ddecbf28d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/jack2/jack2.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 13, 2022, 11:04 a.m. UTC | #1
Hello,

On Fri, 12 Aug 2022 22:56:23 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure:
> 
> Checking for program 'pkg-config'        : not found
> The above check failed, but the checkee is required for --alsa.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/cbdc251980f5571f75281202ebffc04ddecbf28d
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Why is this suddenly happening? Since then it is needed? As usual, we
need to understand since when a particular issue occurs, so that we
have some information on whether the patch needs to be backported to
our maintenance branches or not.

Could you have a look?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/jack2/jack2.mk b/package/jack2/jack2.mk
index 9e56dcdfd8..9d6a3b6479 100644
--- a/package/jack2/jack2.mk
+++ b/package/jack2/jack2.mk
@@ -9,7 +9,7 @@  JACK2_SITE = $(call github,jackaudio,jack2,v$(JACK2_VERSION))
 JACK2_LICENSE = GPL-2.0+ (jack server), LGPL-2.1+ (jack library)
 JACK2_LICENSE_FILES = COPYING
 JACK2_CPE_ID_VENDOR = jackaudio
-JACK2_DEPENDENCIES = alsa-lib
+JACK2_DEPENDENCIES = host-pkgconf alsa-lib
 JACK2_INSTALL_STAGING = YES
 
 JACK2_CONF_OPTS = --alsa --example-tools=no