diff mbox series

[1/1] package/snort: fix sparc build with BR2_OPTIMIZE_FAST

Message ID 20220809184427.2469515-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/snort: fix sparc build with BR2_OPTIMIZE_FAST | expand

Commit Message

Fabrice Fontaine Aug. 9, 2022, 6:44 p.m. UTC
Fix the following sparc build failure with BR2_OPTIMIZE_FAST raised
since bump to version 2.9.19 in commit
65ed981ce0135379b7faeb69519f4e3e666c0717:

cc1: error: argument to '-O' should be a non-negative integer, 'g', 's' or 'fast'

Fixes:
 - http://autobuild.buildroot.org/results/e1a330e1a899fcdf4900e9156d62c90813321e30

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/snort/0008-Fix-NO-OPTIMIZE.patch | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 package/snort/0008-Fix-NO-OPTIMIZE.patch

Comments

Thomas Petazzoni Aug. 15, 2022, 12:37 p.m. UTC | #1
On Tue,  9 Aug 2022 20:44:27 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following sparc build failure with BR2_OPTIMIZE_FAST raised
> since bump to version 2.9.19 in commit
> 65ed981ce0135379b7faeb69519f4e3e666c0717:
> 
> cc1: error: argument to '-O' should be a non-negative integer, 'g', 's' or 'fast'
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/e1a330e1a899fcdf4900e9156d62c90813321e30
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/snort/0008-Fix-NO-OPTIMIZE.patch | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>  create mode 100644 package/snort/0008-Fix-NO-OPTIMIZE.patch

To be honest, I find it pretty crappy that the snort build system
forcefully disables optimizations on SPARC. But oh well, I don't care
much about SPARC, so: applied to master. Thanks!

Thomas
Peter Korsgaard Sept. 16, 2022, 12:23 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following sparc build failure with BR2_OPTIMIZE_FAST raised
 > since bump to version 2.9.19 in commit
 > 65ed981ce0135379b7faeb69519f4e3e666c0717:

 > cc1: error: argument to '-O' should be a non-negative integer, 'g', 's' or 'fast'

 > Fixes:
 >  - http://autobuild.buildroot.org/results/e1a330e1a899fcdf4900e9156d62c90813321e30

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/snort/0008-Fix-NO-OPTIMIZE.patch b/package/snort/0008-Fix-NO-OPTIMIZE.patch
new file mode 100644
index 0000000000..936973fdd6
--- /dev/null
+++ b/package/snort/0008-Fix-NO-OPTIMIZE.patch
@@ -0,0 +1,24 @@ 
+Fix NO_OPTIMIZE
+
+Fix the following build failure when NO_OPTIMIZE is enabled (e.g. on
+sparc) and -Ofast:
+
+cc1: error: argument to '-O' should be a non-negative integer, 'g', 's' or 'fast'
+
+Fixes:
+ - http://autobuild.buildroot.org/results/e1a330e1a899fcdf4900e9156d62c90813321e30
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+
+diff -Nura snort-2.9.19.orig/configure.in snort-2.9.19/configure.in
+--- snort-2.9.19.orig/configure.in	2022-08-09 20:21:00.236777320 +0200
++++ snort-2.9.19/configure.in	2022-08-09 20:29:02.260993315 +0200
+@@ -1694,7 +1694,7 @@
+ 
+ # Set to no optimization regardless of what user or autostuff set
+ if test "x$NO_OPTIMIZE" = "xyes"; then
+-    CFLAGS=`echo $CFLAGS | sed -e "s/-O./-O0/"`
++    CFLAGS=`echo $CFLAGS | sed -e "s/-O[0-9a-z]*/-O0/"`
+ 
+     # in case user override doesn't include -O
+     if echo $CFLAGS | grep -qve -O0 ; then