diff mbox series

[1/1] package/rpi-userland: fix build without libexecinfo

Message ID 20220621183813.1395626-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/rpi-userland: fix build without libexecinfo | expand

Commit Message

Fabrice Fontaine June 21, 2022, 6:38 p.m. UTC
Fix the following build failure without libexecinfo raised since commit
66d7d3bec341188bcfd83fa70b44dd62e0073431:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
EXECINFO_LIBRARY
    linked by target "vcos" in directory /home/buildroot/autobuild/run/instance-1/output-1/build/rpi-userland-14b90ff9d9f031391a299e6e006965d02bfd1bb1/interface/vcos/pthreads

Fixes:
 - http://autobuild.buildroot.org/results/0b4b20e4eed1ed5120f22d29fc24038f268e6cc6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...rface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Arnout Vandecappelle July 23, 2022, 7:37 p.m. UTC | #1
On 21/06/2022 20:38, Fabrice Fontaine wrote:
> Fix the following build failure without libexecinfo raised since commit
> 66d7d3bec341188bcfd83fa70b44dd62e0073431:
> 
> CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
> Please set them or make sure they are set and tested correctly in the CMake files:
> EXECINFO_LIBRARY
>      linked by target "vcos" in directory /home/buildroot/autobuild/run/instance-1/output-1/build/rpi-userland-14b90ff9d9f031391a299e6e006965d02bfd1bb1/interface/vcos/pthreads
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/0b4b20e4eed1ed5120f22d29fc24038f268e6cc6
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   ...rface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch | 8 ++++----
>   1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch b/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
> index e799c82418..6c596395f9 100644
> --- a/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
> +++ b/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
> @@ -1,4 +1,4 @@
> -From 220c37b496f5c883bbfa955ee7fee471e41c34d4 Mon Sep 17 00:00:00 2001
> +From c8270cea98bcce0d22ddc8e2f86eae2c9989efd4 Mon Sep 17 00:00:00 2001
>   From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
>   Date: Fri, 25 Feb 2022 19:21:06 +0100
>   Subject: [PATCH] interface/vcos/pthreads/CMakeLists.txt: fix build with
> @@ -20,7 +20,7 @@ Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
>    1 file changed, 4 insertions(+), 2 deletions(-)
>   
>   diff --git a/interface/vcos/pthreads/CMakeLists.txt b/interface/vcos/pthreads/CMakeLists.txt
> -index 1d81ca3..43aca03 100644
> +index 1d81ca3..100207f 100644
>   --- a/interface/vcos/pthreads/CMakeLists.txt
>   +++ b/interface/vcos/pthreads/CMakeLists.txt
>   @@ -33,12 +33,14 @@ set (SOURCES
> @@ -32,11 +32,11 @@ index 1d81ca3..43aca03 100644
>    if (VCOS_PTHREADS_BUILD_SHARED)
>       add_library (vcos SHARED ${SOURCES})
>   -   target_link_libraries (vcos pthread dl rt)
> -+   target_link_libraries (vcos pthread dl rt ${EXECINFO_LIBRARY})
> ++   target_link_libraries (vcos pthread dl rt $<$<BOOL:${EXECINFO_LIBRARY}>:${EXECINFO_LIBRARY}>)
>    else ()
>       add_library (vcos ${SOURCES})
>   -   target_link_libraries (vcos pthread rt)
> -+   target_link_libraries (vcos pthread rt ${EXECINFO_LIBRARY})
> ++   target_link_libraries (vcos pthread rt $<$<BOOL:${EXECINFO_LIBRARY}>:${EXECINFO_LIBRARY}>)
>    endif ()
>    
>
Peter Korsgaard Aug. 16, 2022, 10:18 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure without libexecinfo raised since commit
 > 66d7d3bec341188bcfd83fa70b44dd62e0073431:

 > CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
 > Please set them or make sure they are set and tested correctly in the CMake files:
 > EXECINFO_LIBRARY
 >     linked by target "vcos" in directory /home/buildroot/autobuild/run/instance-1/output-1/build/rpi-userland-14b90ff9d9f031391a299e6e006965d02bfd1bb1/interface/vcos/pthreads

 > Fixes:
 >  - http://autobuild.buildroot.org/results/0b4b20e4eed1ed5120f22d29fc24038f268e6cc6

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.05.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch b/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
index e799c82418..6c596395f9 100644
--- a/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
+++ b/package/rpi-userland/0006-interface-vcos-pthreads-CMakeLists.txt-fix-build-wit.patch
@@ -1,4 +1,4 @@ 
-From 220c37b496f5c883bbfa955ee7fee471e41c34d4 Mon Sep 17 00:00:00 2001
+From c8270cea98bcce0d22ddc8e2f86eae2c9989efd4 Mon Sep 17 00:00:00 2001
 From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 Date: Fri, 25 Feb 2022 19:21:06 +0100
 Subject: [PATCH] interface/vcos/pthreads/CMakeLists.txt: fix build with
@@ -20,7 +20,7 @@  Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
  1 file changed, 4 insertions(+), 2 deletions(-)
 
 diff --git a/interface/vcos/pthreads/CMakeLists.txt b/interface/vcos/pthreads/CMakeLists.txt
-index 1d81ca3..43aca03 100644
+index 1d81ca3..100207f 100644
 --- a/interface/vcos/pthreads/CMakeLists.txt
 +++ b/interface/vcos/pthreads/CMakeLists.txt
 @@ -33,12 +33,14 @@ set (SOURCES
@@ -32,11 +32,11 @@  index 1d81ca3..43aca03 100644
  if (VCOS_PTHREADS_BUILD_SHARED)
     add_library (vcos SHARED ${SOURCES})
 -   target_link_libraries (vcos pthread dl rt)
-+   target_link_libraries (vcos pthread dl rt ${EXECINFO_LIBRARY})
++   target_link_libraries (vcos pthread dl rt $<$<BOOL:${EXECINFO_LIBRARY}>:${EXECINFO_LIBRARY}>)
  else ()
     add_library (vcos ${SOURCES})
 -   target_link_libraries (vcos pthread rt)
-+   target_link_libraries (vcos pthread rt ${EXECINFO_LIBRARY})
++   target_link_libraries (vcos pthread rt $<$<BOOL:${EXECINFO_LIBRARY}>:${EXECINFO_LIBRARY}>)
  endif ()