diff mbox series

[v2,4/4] boot/uboot: bump to 2022.04

Message ID 20220531105902.204022-5-heiko.thiery@gmail.com
State Accepted
Headers show
Series Bump U-Boot to 2022.04 | expand

Commit Message

Heiko Thiery May 31, 2022, 10:59 a.m. UTC
Since U-Boot 2022.04 a host dependency to gnutls is required if the
U-Boot board configuration has CONFIG_TOOLS_MKEFICAPSULE enabled. So
introduce a new BR U-Boot config option BR2_TARGET_UBOOT_NEEDS_GNUTLS to
solve this problem.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
v2: add new config option as proposed by Thomas

 boot/uboot/Config.in | 12 ++++++++++--
 boot/uboot/uboot.mk  |  4 ++++
 2 files changed, 14 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni June 1, 2022, 9:43 p.m. UTC | #1
Hello Heiko,

On Tue, 31 May 2022 12:59:05 +0200
Heiko Thiery <heiko.thiery@gmail.com> wrote:

> Since U-Boot 2022.04 a host dependency to gnutls is required if the
> U-Boot board configuration has CONFIG_TOOLS_MKEFICAPSULE enabled. So
> introduce a new BR U-Boot config option BR2_TARGET_UBOOT_NEEDS_GNUTLS to
> solve this problem.
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>

I've split this into two patches, one doing the bump, one adding the
new option.

Regarding the bump, you had forgotten the update of uboot.hash with the
hash of the 2022.04 U-Boot tarball.

Also, there was a minor check-package warning related to the formatting
of the help text in the Config.in file.

So, overall, applied to next, with the above issues fixed. Thanks a lot!

Thomas
Heiko Thiery June 2, 2022, 5:06 a.m. UTC | #2
Hi Thomas,

Am Mi., 1. Juni 2022 um 23:43 Uhr schrieb Thomas Petazzoni
<thomas.petazzoni@bootlin.com>:
>
> Hello Heiko,
>
> On Tue, 31 May 2022 12:59:05 +0200
> Heiko Thiery <heiko.thiery@gmail.com> wrote:
>
> > Since U-Boot 2022.04 a host dependency to gnutls is required if the
> > U-Boot board configuration has CONFIG_TOOLS_MKEFICAPSULE enabled. So
> > introduce a new BR U-Boot config option BR2_TARGET_UBOOT_NEEDS_GNUTLS to
> > solve this problem.
> >
> > Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
>
> I've split this into two patches, one doing the bump, one adding the
> new option.

That makes sense.

>
> Regarding the bump, you had forgotten the update of uboot.hash with the
> hash of the 2022.04 U-Boot tarball.

Damn.

> Also, there was a minor check-package warning related to the formatting
> of the help text in the Config.in file.
>
> So, overall, applied to next, with the above issues fixed. Thanks a lot!

Thanks for doing that.

> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 953c36135e..bbd955b5b4 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -41,7 +41,7 @@  choice
 	  Select the specific U-Boot version you want to use
 
 config BR2_TARGET_UBOOT_LATEST_VERSION
-	bool "2022.01"
+	bool "2022.04"
 
 config BR2_TARGET_UBOOT_CUSTOM_VERSION
 	bool "Custom version"
@@ -85,7 +85,7 @@  endif
 
 config BR2_TARGET_UBOOT_VERSION
 	string
-	default "2022.01"	if BR2_TARGET_UBOOT_LATEST_VERSION
+	default "2022.04"	if BR2_TARGET_UBOOT_LATEST_VERSION
 	default BR2_TARGET_UBOOT_CUSTOM_VERSION_VALUE \
 		if BR2_TARGET_UBOOT_CUSTOM_VERSION
 	default "custom"	if BR2_TARGET_UBOOT_CUSTOM_TARBALL
@@ -182,6 +182,14 @@  config BR2_TARGET_UBOOT_NEEDS_LZOP
 	  the case when the board configuration has CONFIG_SPL_LZO
 	  enabled.
 
+config BR2_TARGET_UBOOT_NEEDS_GNUTLS
+	bool "U-Boot needs gnutls"
+	help
+	  Select this option if your U-Boot board configuration
+	  requires gnutls to be available on the host. This is typically
+	  the case when the board configuration has CONFIG_TOOLS_MKEFICAPSULE
+	  enabled.
+
 config BR2_TARGET_UBOOT_NEEDS_ATF_BL31
 	bool "U-Boot needs ATF BL31"
 	depends on BR2_TARGET_ARM_TRUSTED_FIRMWARE
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index cb26fc8d3e..5808e30818 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -227,6 +227,10 @@  ifeq ($(BR2_TARGET_UBOOT_NEEDS_LZOP),y)
 UBOOT_DEPENDENCIES += host-lzop
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_GNUTLS),y)
+UBOOT_DEPENDENCIES += host-gnutls
+endif
+
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE