diff mbox series

[1/1] package/zchunk: fix build with argp-standalone and NLS

Message ID 20220519164038.918088-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/zchunk: fix build with argp-standalone and NLS | expand

Commit Message

Fabrice Fontaine May 19, 2022, 4:40 p.m. UTC
Fix the following build failure with argp-standalone and NLS raised
since commit 5430c8fedd0392e79e0c011825b056fea129980a:

/home/buildroot/autobuild/instance-3/output-1/host/bin/i686-linux-gcc  -o test/zck_cmp_uncomp test/zck_cmp_uncomp.p/zck_cmp_uncomp.c.o -Wl,--as-needed -Wl,--no-undefined -Wl,-O1 '-Wl,-rpath,$ORIGIN/../src/lib' -Wl,-rpath-link,/home/buildroot/autobuild/instance-3/output-1/build/zchunk-1.2.2/build/src/lib -Wl,--start-group src/lib/libzck.so.1.2.2 -largp -Wl,--end-group
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/i686-buildroot-linux-uclibc/sysroot/usr/lib/libargp.a(argp-help.o): in function `arg':
/home/buildroot/autobuild/instance-3/output-1/build/argp-standalone-1.4.1/argp-help.c:936: undefined reference to `libintl_dgettext'

Fixes:
 - http://autobuild.buildroot.org/results/1242d0b15ceb816e946bfc1b31dd39e68227359f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/zchunk/zchunk.mk | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN June 4, 2022, 5:05 p.m. UTC | #1
Fabrice, All,

On 2022-05-19 18:40 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure with argp-standalone and NLS raised
> since commit 5430c8fedd0392e79e0c011825b056fea129980a:
> 
> /home/buildroot/autobuild/instance-3/output-1/host/bin/i686-linux-gcc  -o test/zck_cmp_uncomp test/zck_cmp_uncomp.p/zck_cmp_uncomp.c.o -Wl,--as-needed -Wl,--no-undefined -Wl,-O1 '-Wl,-rpath,$ORIGIN/../src/lib' -Wl,-rpath-link,/home/buildroot/autobuild/instance-3/output-1/build/zchunk-1.2.2/build/src/lib -Wl,--start-group src/lib/libzck.so.1.2.2 -largp -Wl,--end-group
> /home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-3/output-1/host/i686-buildroot-linux-uclibc/sysroot/usr/lib/libargp.a(argp-help.o): in function `arg':
> /home/buildroot/autobuild/instance-3/output-1/build/argp-standalone-1.4.1/argp-help.c:936: undefined reference to `libintl_dgettext'
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/1242d0b15ceb816e946bfc1b31dd39e68227359f
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/zchunk/zchunk.mk | 7 +++++--
>  1 file changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/package/zchunk/zchunk.mk b/package/zchunk/zchunk.mk
> index 5582c21e77..fc91f90431 100644
> --- a/package/zchunk/zchunk.mk
> +++ b/package/zchunk/zchunk.mk
> @@ -9,8 +9,11 @@ ZCHUNK_SITE = $(call github,zchunk,zchunk,$(ZCHUNK_VERSION))
>  ZCHUNK_LICENSE = BSD-2-Clause
>  ZCHUNK_LICENSE_FILES = LICENSE
>  ZCHUNK_INSTALL_STAGING = YES
> -ZCHUNK_DEPENDENCIES = \
> -	$(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
> +
> +ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
> +ZCHUNK_DEPENDENCIES += argp-standalone $(TARGET_NLS_DEPENDENCIES)
> +ZCHUNK_LDFLAGS += $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
> +endif
>  
>  ifeq ($(BR2_PACKAGE_LIBCURL),y)
>  ZCHUNK_DEPENDENCIES += libcurl
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/zchunk/zchunk.mk b/package/zchunk/zchunk.mk
index 5582c21e77..fc91f90431 100644
--- a/package/zchunk/zchunk.mk
+++ b/package/zchunk/zchunk.mk
@@ -9,8 +9,11 @@  ZCHUNK_SITE = $(call github,zchunk,zchunk,$(ZCHUNK_VERSION))
 ZCHUNK_LICENSE = BSD-2-Clause
 ZCHUNK_LICENSE_FILES = LICENSE
 ZCHUNK_INSTALL_STAGING = YES
-ZCHUNK_DEPENDENCIES = \
-	$(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
+
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+ZCHUNK_DEPENDENCIES += argp-standalone $(TARGET_NLS_DEPENDENCIES)
+ZCHUNK_LDFLAGS += $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
+endif
 
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
 ZCHUNK_DEPENDENCIES += libcurl