diff mbox series

[4/5] package/python3-regex: drop host package

Message ID 20220211081730.23068-4-peter@korsgaard.com
State Accepted
Headers show
Series [1/5] package/python3-pycryptodomex: drop host package | expand

Commit Message

Peter Korsgaard Feb. 11, 2022, 8:17 a.m. UTC
Now that host-python2 is gone, the custom python3 variant can be dropped and
instead host support added to python-regex.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/mongodb/mongodb.mk               |  2 +-
 package/python-regex/python-regex.mk     |  1 +
 package/python3-regex/python3-regex.hash |  1 -
 package/python3-regex/python3-regex.mk   | 16 ----------------
 4 files changed, 2 insertions(+), 18 deletions(-)
 delete mode 120000 package/python3-regex/python3-regex.hash
 delete mode 100644 package/python3-regex/python3-regex.mk

Comments

Peter Korsgaard Feb. 11, 2022, 7:09 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Now that host-python2 is gone, the custom python3 variant can be dropped and
 > instead host support added to python-regex.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/mongodb/mongodb.mk b/package/mongodb/mongodb.mk
index e2a58a5f4e..9f6c7d31b8 100644
--- a/package/mongodb/mongodb.mk
+++ b/package/mongodb/mongodb.mk
@@ -19,7 +19,7 @@  MONGODB_DEPENDENCIES = \
 	host-python-cheetah \
 	host-python-psutil \
 	host-python-pyyaml \
-	host-python3-regex \
+	host-python-regex \
 	host-python-requests \
 	host-scons \
 	pcre \
diff --git a/package/python-regex/python-regex.mk b/package/python-regex/python-regex.mk
index c46c4d1614..a90fd579ac 100644
--- a/package/python-regex/python-regex.mk
+++ b/package/python-regex/python-regex.mk
@@ -12,3 +12,4 @@  PYTHON_REGEX_SETUP_TYPE = setuptools
 PYTHON_REGEX_LICENSE = CNRI-Python
 
 $(eval $(python-package))
+$(eval $(host-python-package))
diff --git a/package/python3-regex/python3-regex.hash b/package/python3-regex/python3-regex.hash
deleted file mode 120000
index 274f4dc277..0000000000
--- a/package/python3-regex/python3-regex.hash
+++ /dev/null
@@ -1 +0,0 @@ 
-../python-regex/python-regex.hash
\ No newline at end of file
diff --git a/package/python3-regex/python3-regex.mk b/package/python3-regex/python3-regex.mk
deleted file mode 100644
index 0b71768e9d..0000000000
--- a/package/python3-regex/python3-regex.mk
+++ /dev/null
@@ -1,16 +0,0 @@ 
-################################################################################
-#
-# python3-regex
-#
-################################################################################
-
-# Please keep in sync with package/python-regex/python-regex.mk
-PYTHON3_REGEX_VERSION = 2021.4.4
-PYTHON3_REGEX_SOURCE = regex-$(PYTHON3_REGEX_VERSION).tar.gz
-PYTHON3_REGEX_SITE = https://files.pythonhosted.org/packages/38/3f/4c42a98c9ad7d08c16e7d23b2194a0e4f3b2914662da8bc88986e4e6de1f
-PYTHON3_REGEX_SETUP_TYPE = setuptools
-PYTHON3_REGEX_LICENSE = CNRI-Python
-HOST_PYTHON3_REGEX_DL_SUBDIR = python-regex
-HOST_PYTHON3_REGEX_NEEDS_HOST_PYTHON = python3
-
-$(eval $(host-python-package))