diff mbox series

package/python3: unconditionally install python{, -config} symlinks

Message ID 20220210212429.31856-1-peter@korsgaard.com
State Accepted
Headers show
Series package/python3: unconditionally install python{, -config} symlinks | expand

Commit Message

Peter Korsgaard Feb. 10, 2022, 9:24 p.m. UTC
Now that host-python2 is gone, it makes sense to unconditionally install the
symlinks for the host, similar to how it is done for the target.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/python3/python3.mk | 6 ------
 1 file changed, 6 deletions(-)

Comments

Peter Korsgaard Feb. 11, 2022, 7:08 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Now that host-python2 is gone, it makes sense to unconditionally install the
 > symlinks for the host, similar to how it is done for the target.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index 6af7488ddd..3a334fb28d 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -262,18 +262,12 @@  endef
 
 PYTHON3_POST_INSTALL_TARGET_HOOKS += PYTHON3_INSTALL_SYMLINK
 
-# Some packages may have build scripts requiring python3, whatever is the
-# python version chosen for the target.
-# Only install the python symlink in the host tree if python3 is enabled
-# for the target.
-ifeq ($(BR2_PACKAGE_PYTHON3),y)
 define HOST_PYTHON3_INSTALL_SYMLINK
 	ln -fs python3 $(HOST_DIR)/bin/python
 	ln -fs python3-config $(HOST_DIR)/bin/python-config
 endef
 
 HOST_PYTHON3_POST_INSTALL_HOOKS += HOST_PYTHON3_INSTALL_SYMLINK
-endif
 
 # Provided to other packages
 PYTHON3_PATH = $(STAGING_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/