diff mbox series

[095/107] package/python-pathlib2: drop python2 specific package

Message ID 20220209165213.4498-96-peter@korsgaard.com
State Accepted
Headers show
Series Drop python 2.7 | expand

Commit Message

Peter Korsgaard Feb. 9, 2022, 4:52 p.m. UTC
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Config.in.legacy                             |  6 ++++++
 DEVELOPERS                                   |  1 -
 package/Config.in                            |  1 -
 package/python-pathlib2/Config.in            | 13 -------------
 package/python-pathlib2/python-pathlib2.hash |  5 -----
 package/python-pathlib2/python-pathlib2.mk   | 14 --------------
 6 files changed, 6 insertions(+), 34 deletions(-)
 delete mode 100644 package/python-pathlib2/Config.in
 delete mode 100644 package/python-pathlib2/python-pathlib2.hash
 delete mode 100644 package/python-pathlib2/python-pathlib2.mk
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 386f94e72b..74317a2d7c 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,12 @@  endif
 
 comment "Legacy options removed in 2022.02"
 
+config BR2_PACKAGE_PYTHON_PATHLIB2
+	bool "python-pathlib2 removed"
+	select BR2_LEGACY
+	help
+	  Package was removed together with python 2.7 support.
+
 config BR2_PACKAGE_PYTHON_PAM
 	bool "python-pam removed"
 	select BR2_LEGACY
diff --git a/DEVELOPERS b/DEVELOPERS
index a6ea3793ea..07f9304766 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -145,7 +145,6 @@  F:	package/mpd/
 N:	Andrey Smirnov <andrew.smirnov@gmail.com>
 F:	package/python-decorator/
 F:	package/python-ipython-genutils/
-F:	package/python-pathlib2/
 F:	package/python-pickleshare/
 F:	package/python-scandir/
 F:	package/python-simplegeneric/
diff --git a/package/Config.in b/package/Config.in
index 73e8901a1d..3c55dec6c5 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1118,7 +1118,6 @@  menu "External python modules"
 	source "package/python-paramiko/Config.in"
 	source "package/python-parso/Config.in"
 	source "package/python-passlib/Config.in"
-	source "package/python-pathlib2/Config.in"
 	source "package/python-pathpy/Config.in"
 	source "package/python-pathtools/Config.in"
 	source "package/python-pathvalidate/Config.in"
diff --git a/package/python-pathlib2/Config.in b/package/python-pathlib2/Config.in
deleted file mode 100644
index e28de4c12e..0000000000
--- a/package/python-pathlib2/Config.in
+++ /dev/null
@@ -1,13 +0,0 @@ 
-config BR2_PACKAGE_PYTHON_PATHLIB2
-	bool "python-pathlib2"
-	depends on BR2_PACKAGE_PYTHON
-	select BR2_PACKAGE_PYTHON_SIX # runtime
-	help
-	  Object-oriented filesystem paths.
-
-	  The goal of pathlib2 is to provide a backport of standard
-	  pathlib module which tracks the standard library module, so
-	  all the newest features of the standard pathlib can be used
-	  also on older Python versions.
-
-	  https://pypi.python.org/pypi/pathlib2
diff --git a/package/python-pathlib2/python-pathlib2.hash b/package/python-pathlib2/python-pathlib2.hash
deleted file mode 100644
index ebd197b62e..0000000000
--- a/package/python-pathlib2/python-pathlib2.hash
+++ /dev/null
@@ -1,5 +0,0 @@ 
-# md5, sha256 from https://pypi.org/pypi/pathlib2/json
-md5  e50a0cf94e406c5110b3aed535626e9e  pathlib2-2.3.6.tar.gz
-sha256  7d8bcb5555003cdf4a8d2872c538faa3a0f5d20630cb360e518ca3b981795e5f  pathlib2-2.3.6.tar.gz
-# Locally computed sha256 checksums
-sha256  861f813004a151ac77024ad445794653809ddf8a7572aee7bab18d11df2ba1c6  LICENSE.rst
diff --git a/package/python-pathlib2/python-pathlib2.mk b/package/python-pathlib2/python-pathlib2.mk
deleted file mode 100644
index 4bcfea78fb..0000000000
--- a/package/python-pathlib2/python-pathlib2.mk
+++ /dev/null
@@ -1,14 +0,0 @@ 
-################################################################################
-#
-# python-pathlib2
-#
-################################################################################
-
-PYTHON_PATHLIB2_VERSION = 2.3.6
-PYTHON_PATHLIB2_SOURCE = pathlib2-$(PYTHON_PATHLIB2_VERSION).tar.gz
-PYTHON_PATHLIB2_SITE = https://files.pythonhosted.org/packages/df/16/e9d6bcf1aed52a55bc1696324ab22586716053b3e97b85266e0f3ad36bae
-PYTHON_PATHLIB2_LICENSE = MIT
-PYTHON_PATHLIB2_LICENSE_FILES = LICENSE.rst
-PYTHON_PATHLIB2_SETUP_TYPE = setuptools
-
-$(eval $(python-package))