diff mbox series

[007/107] package/cracklib: move python support to python3

Message ID 20220209165213.4498-8-peter@korsgaard.com
State Accepted
Headers show
Series Drop python 2.7 | expand

Commit Message

Peter Korsgaard Feb. 9, 2022, 4:50 p.m. UTC
The configure script needs a bit of help to detect the python version.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/cracklib/cracklib.mk | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/cracklib/cracklib.mk b/package/cracklib/cracklib.mk
index 8e6a844f11..46917b7926 100644
--- a/package/cracklib/cracklib.mk
+++ b/package/cracklib/cracklib.mk
@@ -20,9 +20,12 @@  else
 CRACKLIB_CONF_OPTS += --without-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON),y)
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
 CRACKLIB_CONF_OPTS += --with-python
-CRACKLIB_DEPENDENCIES += python
+CRACKLIB_CONF_ENV += \
+	ac_cv_path_PYTHON=$(HOST_DIR)/bin/python3 \
+	am_cv_python_version=$(PYTHON3_VERSION_MAJOR)
+CRACKLIB_DEPENDENCIES += python3
 else
 CRACKLIB_CONF_OPTS += --without-python
 endif