diff mbox series

[1/1] package/pkg-cargo: fix debug build

Message ID 20220129094222.3583303-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/pkg-cargo: fix debug build | expand

Commit Message

Fabrice Fontaine Jan. 29, 2022, 9:42 a.m. UTC
There is no --debug mode for cargo resulting in the following build
failure in ripgrep since its conversion to cargo infrastructure in
commit 342fd3e7350479dc368541ac77a5130ebb53194c:

error: Found argument '--debug' which wasn't expected, or isn't valid in this context

Fixes:
 - http://autobuild.buildroot.org/results/772ebdd6a39950457a59419bdc1376cb0e0a3611

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pkg-cargo.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Jan. 30, 2022, 2:55 p.m. UTC | #1
On Sat, 29 Jan 2022 10:42:22 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> There is no --debug mode for cargo resulting in the following build
> failure in ripgrep since its conversion to cargo infrastructure in
> commit 342fd3e7350479dc368541ac77a5130ebb53194c:
> 
> error: Found argument '--debug' which wasn't expected, or isn't valid in this context
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/772ebdd6a39950457a59419bdc1376cb0e0a3611
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/pkg-cargo.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

However, I'm wondering if we shouldn't instead use:

	--profile=release

and

	--profile=dev

See https://doc.rust-lang.org/cargo/reference/profiles.html

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/pkg-cargo.mk b/package/pkg-cargo.mk
index 614d46ad64..e74a8358bc 100644
--- a/package/pkg-cargo.mk
+++ b/package/pkg-cargo.mk
@@ -104,7 +104,7 @@  define $(2)_BUILD_CMDS
 		$$($(2)_CARGO_ENV) \
 		cargo build \
 			--offline \
-			$$(if $$(BR2_ENABLE_DEBUG),--debug,--release) \
+			$$(if $$(BR2_ENABLE_DEBUG),,--release) \
 			--manifest-path Cargo.toml \
 			--locked \
 			$$($(2)_CARGO_BUILD_OPTS)