diff mbox series

[1/1] package/php-apcu: fix build without __sync_*_4 intrinsics

Message ID 20220115111622.1910388-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/php-apcu: fix build without __sync_*_4 intrinsics | expand

Commit Message

Fabrice Fontaine Jan. 15, 2022, 11:16 a.m. UTC
Fix the following build failure raised since the addition of the package
in commit 8ddeeffa186d8bce875ac713c1e71483c618842a:

configure: error: Compiler does not support atomics

--enable-apcu-rwlocks can't be used until
https://github.com/krakjoe/apcu/pull/430 is merged (and autoreconf does
not work either)

Fixes:
 - http://autobuild.buildroot.org/results/efa/efa3b4406f87a1e9521b66f392a6fa19ac01f0cd/build-end.log

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/php-apcu/php-apcu.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Arnout Vandecappelle Feb. 1, 2022, 9:44 p.m. UTC | #1
On 15/01/2022 12:16, Fabrice Fontaine wrote:
> Fix the following build failure raised since the addition of the package
> in commit 8ddeeffa186d8bce875ac713c1e71483c618842a:
> 
> configure: error: Compiler does not support atomics
> 
> --enable-apcu-rwlocks can't be used until
> https://github.com/krakjoe/apcu/pull/430 is merged (and autoreconf does
> not work either)
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/efa/efa3b4406f87a1e9521b66f392a6fa19ac01f0cd/build-end.log
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/php-apcu/php-apcu.mk | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/package/php-apcu/php-apcu.mk b/package/php-apcu/php-apcu.mk
> index ce59611d8f..3ac062e772 100644
> --- a/package/php-apcu/php-apcu.mk
> +++ b/package/php-apcu/php-apcu.mk
> @@ -22,4 +22,8 @@ define PHP_APCU_PHPIZE
>   endef
>   PHP_APCU_PRE_CONFIGURE_HOOKS += PHP_APCU_PHPIZE
>   
> +ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
> +PHP_APCU_CONF_OPTS += --disable-apcu-rwlocks
> +endif
> +
>   $(eval $(autotools-package))
diff mbox series

Patch

diff --git a/package/php-apcu/php-apcu.mk b/package/php-apcu/php-apcu.mk
index ce59611d8f..3ac062e772 100644
--- a/package/php-apcu/php-apcu.mk
+++ b/package/php-apcu/php-apcu.mk
@@ -22,4 +22,8 @@  define PHP_APCU_PHPIZE
 endef
 PHP_APCU_PRE_CONFIGURE_HOOKS += PHP_APCU_PHPIZE
 
+ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
+PHP_APCU_CONF_OPTS += --disable-apcu-rwlocks
+endif
+
 $(eval $(autotools-package))