diff mbox series

[2/2] package/domoticz: depends on minizip-zlib

Message ID 20220108224337.3702128-2-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/2] package/minizip: add minizip-zlib support | expand

Commit Message

Fabrice Fontaine Jan. 8, 2022, 10:43 p.m. UTC
Depends on minizip-zlib and so drop git submodules

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/domoticz/Config.in     | 4 ++++
 package/domoticz/domoticz.hash | 2 +-
 package/domoticz/domoticz.mk   | 8 ++++----
 3 files changed, 9 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/package/domoticz/Config.in b/package/domoticz/Config.in
index 4324d13cee..fa7fd546fa 100644
--- a/package/domoticz/Config.in
+++ b/package/domoticz/Config.in
@@ -10,6 +10,7 @@  config BR2_PACKAGE_DOMOTICZ
 	depends on BR2_PACKAGE_LUA_5_3
 	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS # boost-thread
 	depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # exception_ptr
+	depends on BR2_PACKAGE_MINIZIP_ZLIB
 	select BR2_PACKAGE_BOOST
 	select BR2_PACKAGE_BOOST_ATOMIC
 	select BR2_PACKAGE_BOOST_DATE_TIME
@@ -43,3 +44,6 @@  comment "domoticz needs lua 5.3 and a toolchain w/ C++, gcc >= 6, NPTL, wchar, d
 
 comment "domoticz needs exception_ptr"
 	depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
+
+comment "domoticz needs minizip-zlib"
+	depends on !BR2_PACKAGE_MINIZIP_ZLIB
diff --git a/package/domoticz/domoticz.hash b/package/domoticz/domoticz.hash
index dcd5bead1e..2c6c837e64 100644
--- a/package/domoticz/domoticz.hash
+++ b/package/domoticz/domoticz.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  d8e99e0f96873aa105b57f73656ef7a14c89e0acf2649b2d4ef1167b14bab4b2  domoticz-2021.1-br1.tar.gz
+sha256  c4dc3455edae8bf00d2e950002f70d5b90ac577b1559ef7ada6870d970069fbb  domoticz-2021.1.tar.gz
 sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  License.txt
diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
index f142791830..0d1088d395 100644
--- a/package/domoticz/domoticz.mk
+++ b/package/domoticz/domoticz.mk
@@ -5,9 +5,7 @@ 
 ################################################################################
 
 DOMOTICZ_VERSION = 2021.1
-DOMOTICZ_SITE = https://github.com/domoticz/domoticz
-DOMOTICZ_SITE_METHOD = git
-DOMOTICZ_GIT_SUBMODULES = YES
+DOMOTICZ_SITE = $(call github,domoticz,domoticz,$(DOMOTICZ_VERSION))
 DOMOTICZ_LICENSE = GPL-3.0
 DOMOTICZ_LICENSE_FILES = License.txt
 DOMOTICZ_CPE_ID_VENDOR = domoticz
@@ -19,6 +17,7 @@  DOMOTICZ_DEPENDENCIES = \
 	jsoncpp \
 	libcurl \
 	lua \
+	minizip \
 	mosquitto \
 	openssl \
 	sqlite \
@@ -34,10 +33,11 @@  DOMOTICZ_CONF_OPTS += \
 	-DUSE_OPENSSL_STATIC=OFF
 
 # Do not use any built-in libraries which are enabled by default for
-# jsoncpp, fmt, sqlite and mqtt
+# jsoncpp, fmt, minizip, sqlite and mqtt
 DOMOTICZ_CONF_OPTS += \
 	-DUSE_BUILTIN_JSONCPP=OFF \
 	-DUSE_BUILTIN_LIBFMT=OFF \
+	-DUSE_BUILTIN_MINIZIP=OFF \
 	-DUSE_BUILTIN_SQLITE=OFF \
 	-DUSE_BUILTIN_MQTT=OFF