diff mbox series

[2/2] package/lxc: add liburing optional dependency

Message ID 20220104181107.3171973-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/liburing: new package | expand

Commit Message

Fabrice Fontaine Jan. 4, 2022, 6:11 p.m. UTC
liburing is an optional dependency (enabed by default) since version
4.0.11 and
https://github.com/lxc/lxc/commit/b1f9aee5c466b5a6d88582375ea15971d846d18b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/lxc/lxc.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Jan. 7, 2022, 7:15 p.m. UTC | #1
On Tue,  4 Jan 2022 19:11:07 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> liburing is an optional dependency (enabed by default) since version
> 4.0.11 and
> https://github.com/lxc/lxc/commit/b1f9aee5c466b5a6d88582375ea15971d846d18b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/lxc/lxc.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/lxc/lxc.mk b/package/lxc/lxc.mk
index 4d63fc14cb..08f64bcec7 100644
--- a/package/lxc/lxc.mk
+++ b/package/lxc/lxc.mk
@@ -44,6 +44,13 @@  else
 LXC_CONF_OPTS += --disable-selinux
 endif
 
+ifeq ($(BR2_PACKAGE_LIBURING),y)
+LXC_CONF_OPTS += --enable-liburing
+LXC_DEPENDENCIES += liburing
+else
+LXC_CONF_OPTS += --disable-liburing
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LXC_CONF_OPTS += --enable-openssl
 LXC_DEPENDENCIES += openssl