diff mbox series

[1/3] package/flare-engine: enable ogg support in SDL2-mixer via Tremor

Message ID 20211231124728.1692301-1-romain.naour@gmail.com
State Accepted
Headers show
Series [1/3] package/flare-engine: enable ogg support in SDL2-mixer via Tremor | expand

Commit Message

Romain Naour Dec. 31, 2021, 12:47 p.m. UTC
Flare games use OGG audio file format througt SDL2-mixer.

Without OGG support, flare-engine trigger a lot of errors in its
log and fail to start the game.

ERROR: SoundManager: ItemManager: Loading sound /usr/share/flare/mods/fantasycore/soundfx/inventory/inventory_gem.ogg (soundfx/inventory/inventory_gem.ogg) failed: Unrecognized audio format

Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
 package/flare-engine/Config.in       | 1 +
 package/flare-engine/flare-engine.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Jan. 26, 2022, 1:07 p.m. UTC | #1
>>>>> "Romain" == Romain Naour <romain.naour@gmail.com> writes:

 > Flare games use OGG audio file format througt SDL2-mixer.
 > Without OGG support, flare-engine trigger a lot of errors in its
 > log and fail to start the game.

 > ERROR: SoundManager: ItemManager: Loading sound /usr/share/flare/mods/fantasycore/soundfx/inventory/inventory_gem.ogg (soundfx/inventory/inventory_gem.ogg) failed: Unrecognized audio format

 > Signed-off-by: Romain Naour <romain.naour@gmail.com>

Committed to 2021.02.x and 2021.11.x, thanks.
diff mbox series

Patch

diff --git a/package/flare-engine/Config.in b/package/flare-engine/Config.in
index d08b740af3..9c997c2b9a 100644
--- a/package/flare-engine/Config.in
+++ b/package/flare-engine/Config.in
@@ -7,6 +7,7 @@  config BR2_PACKAGE_FLARE_ENGINE
 	select BR2_PACKAGE_SDL2_IMAGE
 	select BR2_PACKAGE_SDL2_MIXER
 	select BR2_PACKAGE_SDL2_TTF
+	select BR2_PACKAGE_TREMOR # for SDL2_mixer ogg support
 	help
 	  Flare (Free Libre Action Roleplaying Engine) is a simple game
 	  engine built to handle a very specific kind of game:
diff --git a/package/flare-engine/flare-engine.mk b/package/flare-engine/flare-engine.mk
index 14d2681fda..d722a42208 100644
--- a/package/flare-engine/flare-engine.mk
+++ b/package/flare-engine/flare-engine.mk
@@ -9,7 +9,7 @@  FLARE_ENGINE_SITE = $(call github,flareteam,flare-engine,v$(FLARE_ENGINE_VERSION
 FLARE_ENGINE_LICENSE = GPL-3.0+
 FLARE_ENGINE_LICENSE_FILES = COPYING
 
-FLARE_ENGINE_DEPENDENCIES += sdl2 sdl2_image sdl2_mixer sdl2_ttf
+FLARE_ENGINE_DEPENDENCIES += sdl2 sdl2_image sdl2_mixer sdl2_ttf tremor
 
 # Don't use /usr/games and /usr/share/games
 FLARE_ENGINE_CONF_OPTS += -DBINDIR=bin -DDATADIR=share/flare