diff mbox series

[1/1] package/efl: handle input option

Message ID 20211230221904.3064022-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/efl: handle input option | expand

Commit Message

Fabrice Fontaine Dec. 30, 2021, 10:19 p.m. UTC
Commit 2d7a3e48c574c05346b66f79cdb75ecdfa7f074e forgot to manage input
option on target which was added (and enabled by default) by
https://git.enlightenment.org/core/efl.git/commit/?id=0c2cf7e1bf7ca547655d25aaea30d081101b42be
resulting in the following build failure when eeze is disabled:

../output-1/build/efl-1.26.0/src/lib/elput/meson.build:1:0: ERROR: Unknown variable "eeze".

Fixes:
 - http://autobuild.buildroot.org/results/4a840c54bad9748b5748738378a0352d02de1f7e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/efl/Config.in | 13 +++++++++++++
 package/efl/efl.mk    |  7 +++++++
 2 files changed, 20 insertions(+)

Comments

Thomas Petazzoni Dec. 30, 2021, 10:39 p.m. UTC | #1
On Thu, 30 Dec 2021 23:19:04 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit 2d7a3e48c574c05346b66f79cdb75ecdfa7f074e forgot to manage input
> option on target which was added (and enabled by default) by
> https://git.enlightenment.org/core/efl.git/commit/?id=0c2cf7e1bf7ca547655d25aaea30d081101b42be
> resulting in the following build failure when eeze is disabled:
> 
> ../output-1/build/efl-1.26.0/src/lib/elput/meson.build:1:0: ERROR: Unknown variable "eeze".
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/4a840c54bad9748b5748738378a0352d02de1f7e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/efl/Config.in | 13 +++++++++++++
>  package/efl/efl.mk    |  7 +++++++
>  2 files changed, 20 insertions(+)

This looks good to me, I'll wait for a Review/Ack from Romain to be sure.

Best regards,

Thomas
Romain Naour Dec. 30, 2021, 11:06 p.m. UTC | #2
Le 30/12/2021 à 23:19, Fabrice Fontaine a écrit :
> Commit 2d7a3e48c574c05346b66f79cdb75ecdfa7f074e forgot to manage input
> option on target which was added (and enabled by default) by
> https://git.enlightenment.org/core/efl.git/commit/?id=0c2cf7e1bf7ca547655d25aaea30d081101b42be
> resulting in the following build failure when eeze is disabled:
> 
> ../output-1/build/efl-1.26.0/src/lib/elput/meson.build:1:0: ERROR: Unknown variable "eeze".
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/4a840c54bad9748b5748738378a0352d02de1f7e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/efl/Config.in | 13 +++++++++++++
>  package/efl/efl.mk    |  7 +++++++
>  2 files changed, 20 insertions(+)
> 
> diff --git a/package/efl/Config.in b/package/efl/Config.in
> index 05ded72cf7..d873c77ac6 100644
> --- a/package/efl/Config.in
> +++ b/package/efl/Config.in
> @@ -85,6 +85,19 @@ config BR2_PACKAGE_EFL_LIBFRIBIDI
>  	  so you may also trigger code paths with bugs that are never
>  	  normally used.
>  
> +config BR2_PACKAGE_EFL_LIBINPUT
> +	bool "Enable libinput support (recommended)"
> +	default y
> +	depends on BR2_PACKAGE_HAS_UDEV # libinput
> +	select BR2_PACKAGE_EFL_EEZE
> +	select BR2_PACKAGE_LIBINPUT
> +	select BR2_PACKAGE_LIBXKBCOMMON
> +	help
> +	  Libinput is used to support gesture recognition.
> +
> +comment "libinput needs udev /dev management"
> +	depends on !BR2_PACKAGE_HAS_UDEV
> +

Maybe we can improve BR2_PACKAGE_EFL_DRM option:

config BR2_PACKAGE_EFL_DRM
	bool "Evas DRM Engine"
	depends on BR2_PACKAGE_EFL_EEZE
	depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm
	depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # require libgbm from mesa3d
	select BR2_PACKAGE_LIBDRM
	select BR2_PACKAGE_LIBINPUT # For elput
	select BR2_PACKAGE_LIBXKBCOMMON
	help
	  This option enable building support for the Evas DRM Engine.

	  Since efl 1.23.x, the drm option enable the elput library
	  which is an efl abstraction for the libinput library which
	  can be used by various other subsystems (ecore_fb, ecore_drm,
	  etc) to handle interfacing with libinput without having to
	  duplicate the code in each subsystem.

>  config BR2_PACKAGE_EFL_LIBSNDFILE
>  	bool "Enable libsndfile support (recommended)"
>  	default y
> diff --git a/package/efl/efl.mk b/package/efl/efl.mk
> index 46bce29305..642b37a434 100644
> --- a/package/efl/efl.mk
> +++ b/package/efl/efl.mk
> @@ -67,6 +67,13 @@ else
>  EFL_CONF_OPTS += -Deeze=false
>  endif
>  
> +ifeq ($(BR2_PACKAGE_EFL_LIBINPUT),y)
> +EFL_DEPENDENCIES += libinput libxkbcommon

libxkbcommon is added by:

EFL_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBXKBCOMMON),libxkbcommon)

(this line could be refactored)

Best regards,
Romain


> +EFL_CONF_OPTS += -Dinput=true
> +else
> +EFL_CONF_OPTS += -Dinput=false
> +endif
> +
>  ifeq ($(BR2_PACKAGE_EFL_UTIL_LINUX_LIBMOUNT),y)
>  EFL_DEPENDENCIES += util-linux
>  EFL_CONF_OPTS += -Dlibmount=true
>
diff mbox series

Patch

diff --git a/package/efl/Config.in b/package/efl/Config.in
index 05ded72cf7..d873c77ac6 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -85,6 +85,19 @@  config BR2_PACKAGE_EFL_LIBFRIBIDI
 	  so you may also trigger code paths with bugs that are never
 	  normally used.
 
+config BR2_PACKAGE_EFL_LIBINPUT
+	bool "Enable libinput support (recommended)"
+	default y
+	depends on BR2_PACKAGE_HAS_UDEV # libinput
+	select BR2_PACKAGE_EFL_EEZE
+	select BR2_PACKAGE_LIBINPUT
+	select BR2_PACKAGE_LIBXKBCOMMON
+	help
+	  Libinput is used to support gesture recognition.
+
+comment "libinput needs udev /dev management"
+	depends on !BR2_PACKAGE_HAS_UDEV
+
 config BR2_PACKAGE_EFL_LIBSNDFILE
 	bool "Enable libsndfile support (recommended)"
 	default y
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 46bce29305..642b37a434 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -67,6 +67,13 @@  else
 EFL_CONF_OPTS += -Deeze=false
 endif
 
+ifeq ($(BR2_PACKAGE_EFL_LIBINPUT),y)
+EFL_DEPENDENCIES += libinput libxkbcommon
+EFL_CONF_OPTS += -Dinput=true
+else
+EFL_CONF_OPTS += -Dinput=false
+endif
+
 ifeq ($(BR2_PACKAGE_EFL_UTIL_LINUX_LIBMOUNT),y)
 EFL_DEPENDENCIES += util-linux
 EFL_CONF_OPTS += -Dlibmount=true