diff mbox series

[v2,3/3] package/python3-setuptools: bump to version 60.2.0

Message ID 20211230204103.282138-3-aduskett@gmail.com
State Changes Requested
Headers show
Series [v2,1/3] package/python-setuptools: bump to version 59.8.0 and split python2 version | expand

Commit Message

Adam Duskett Dec. 30, 2021, 8:41 p.m. UTC
Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/python-setuptools/59.8.0/python-setuptools.hash       | 4 ----
 .../{59.8.0 => 60.2.0}/0001-add-executable.patch              | 0
 package/python-setuptools/60.2.0/python-setuptools.hash       | 4 ++++
 package/python-setuptools/python-setuptools.mk                | 4 ++--
 package/python3-setuptools/0001-add-executable.patch          | 2 +-
 package/python3-setuptools/python3-setuptools.hash            | 2 +-
 package/python3-setuptools/python3-setuptools.mk              | 4 ++--
 7 files changed, 10 insertions(+), 10 deletions(-)
 delete mode 100644 package/python-setuptools/59.8.0/python-setuptools.hash
 rename package/python-setuptools/{59.8.0 => 60.2.0}/0001-add-executable.patch (100%)
 create mode 100644 package/python-setuptools/60.2.0/python-setuptools.hash

Comments

Thomas Petazzoni Dec. 30, 2021, 10:32 p.m. UTC | #1
On Thu, 30 Dec 2021 12:41:03 -0800
Adam Duskett <aduskett@gmail.com> wrote:

> Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ---
>  package/python-setuptools/59.8.0/python-setuptools.hash       | 4 ----
>  .../{59.8.0 => 60.2.0}/0001-add-executable.patch              | 0
>  package/python-setuptools/60.2.0/python-setuptools.hash       | 4 ++++
>  package/python-setuptools/python-setuptools.mk                | 4 ++--
>  package/python3-setuptools/0001-add-executable.patch          | 2 +-
>  package/python3-setuptools/python3-setuptools.hash            | 2 +-
>  package/python3-setuptools/python3-setuptools.mk              | 4 ++--
>  7 files changed, 10 insertions(+), 10 deletions(-)
>  delete mode 100644 package/python-setuptools/59.8.0/python-setuptools.hash
>  rename package/python-setuptools/{59.8.0 => 60.2.0}/0001-add-executable.patch (100%)
>  create mode 100644 package/python-setuptools/60.2.0/python-setuptools.hash

Unfortunately, this patch causes a build failure of python3:

  https://paste.ack.tf/23e101@raw

I'll mark it as Changes Requested for now, until this issue gets
resolved.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/python-setuptools/59.8.0/python-setuptools.hash b/package/python-setuptools/59.8.0/python-setuptools.hash
deleted file mode 100644
index 285919639d..0000000000
--- a/package/python-setuptools/59.8.0/python-setuptools.hash
+++ /dev/null
@@ -1,4 +0,0 @@ 
-# From https://pypi.org/pypi/setuptools/json
-md5  675f2089d970bf0bbfc3f49c80e4c7c3  setuptools-59.8.0.tar.gz
-sha256  09980778aa734c3037a47997f28d6db5ab18bdf2af0e49f719bfc53967fd2e82  setuptools-59.8.0.tar.gz
-sha256  db3f0246b1f9278f15845b99fec478b8b506eb76487993722f8c6e254285faf8  LICENSE
diff --git a/package/python-setuptools/59.8.0/0001-add-executable.patch b/package/python-setuptools/60.2.0/0001-add-executable.patch
similarity index 100%
rename from package/python-setuptools/59.8.0/0001-add-executable.patch
rename to package/python-setuptools/60.2.0/0001-add-executable.patch
diff --git a/package/python-setuptools/60.2.0/python-setuptools.hash b/package/python-setuptools/60.2.0/python-setuptools.hash
new file mode 100644
index 0000000000..2c8fb96bb7
--- /dev/null
+++ b/package/python-setuptools/60.2.0/python-setuptools.hash
@@ -0,0 +1,4 @@ 
+# From https://pypi.org/pypi/setuptools/json
+md5  3638c36eaf67f24bacb147c011fe6d30  setuptools-60.2.0.tar.gz
+sha256  675fcebecb43c32eb930481abf907619137547f4336206e4d673180242e1a278  setuptools-60.2.0.tar.gz
+sha256  db3f0246b1f9278f15845b99fec478b8b506eb76487993722f8c6e254285faf8  LICENSE
diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
index 3e48e56be4..766eb724cd 100644
--- a/package/python-setuptools/python-setuptools.mk
+++ b/package/python-setuptools/python-setuptools.mk
@@ -7,9 +7,9 @@ 
 # For the target variant, we adapt the version depending on whether
 # Python 3.x or 2.x is selected for the target.
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
-PYTHON_SETUPTOOLS_VERSION = 59.8.0
+PYTHON_SETUPTOOLS_VERSION = 60.2.0
 PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON3_SETUPTOOLS_VERSION).tar.gz
-PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/75/2bc7bef4d668f9caa9c6ed3f3187989922765403198243040d08d2a52725
+PYTHON_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2
 else # Python
 PYTHON_SETUPTOOLS_VERSION = 44.0.0
 PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).zip
diff --git a/package/python3-setuptools/0001-add-executable.patch b/package/python3-setuptools/0001-add-executable.patch
index 6fc7595a8d..442a3bda2e 120000
--- a/package/python3-setuptools/0001-add-executable.patch
+++ b/package/python3-setuptools/0001-add-executable.patch
@@ -1 +1 @@ 
-../python-setuptools/59.8.0/0001-add-executable.patch
\ No newline at end of file
+../python-setuptools/60.2.0/0001-add-executable.patch
\ No newline at end of file
diff --git a/package/python3-setuptools/python3-setuptools.hash b/package/python3-setuptools/python3-setuptools.hash
index 91d8bc0887..fa4b0bd23f 120000
--- a/package/python3-setuptools/python3-setuptools.hash
+++ b/package/python3-setuptools/python3-setuptools.hash
@@ -1 +1 @@ 
-../python-setuptools/59.8.0/python-setuptools.hash
\ No newline at end of file
+../python-setuptools/60.2.0/python-setuptools.hash
\ No newline at end of file
diff --git a/package/python3-setuptools/python3-setuptools.mk b/package/python3-setuptools/python3-setuptools.mk
index d459094c26..ecf829450d 100644
--- a/package/python3-setuptools/python3-setuptools.mk
+++ b/package/python3-setuptools/python3-setuptools.mk
@@ -6,9 +6,9 @@ 
 
 # Please keep in sync with
 # package/python-setuptools/python-setuptools.mk
-PYTHON3_SETUPTOOLS_VERSION = 59.8.0
+PYTHON3_SETUPTOOLS_VERSION = 60.2.0
 PYTHON3_SETUPTOOLS_SOURCE = setuptools-$(PYTHON3_SETUPTOOLS_VERSION).tar.gz
-PYTHON3_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/ef/75/2bc7bef4d668f9caa9c6ed3f3187989922765403198243040d08d2a52725
+PYTHON3_SETUPTOOLS_SITE = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2
 PYTHON3_SETUPTOOLS_LICENSE = MIT
 PYTHON3_SETUPTOOLS_LICENSE_FILES = LICENSE
 PYTHON3_SETUPTOOLS_CPE_ID_VENDOR = python