diff mbox series

[1/1] package/grep: fix build with microblazeel and or1k

Message ID 20211218101238.565215-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/grep: fix build with microblazeel and or1k | expand

Commit Message

Fabrice Fontaine Dec. 18, 2021, 10:12 a.m. UTC
Fix the following build failure with microblazeel and or1k raised since
bump to version 3.7 in commit f1f0b633eb1c4bc006b95daad8f299028e89d19d:

sigsegv.c: In function 'sigsegv_handler':
sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
  979 |                       : vma.is_near_this (addr, &vma))
      |

Fixes:
 - http://autobuild.buildroot.org/results/78142463ba8cc5f6c1bf15295095a271422294f4
 - http://autobuild.buildroot.org/results/f300b1b5e958f096a9d58197a44dcf0c2abd3585

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...01-sigsegv-fix-build-on-microblazeel.patch | 32 +++++++++++++++++++
 .../grep/0002-sigsegv-fix-build-on-or1k.patch | 32 +++++++++++++++++++
 package/grep/grep.mk                          |  2 ++
 3 files changed, 66 insertions(+)
 create mode 100644 package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
 create mode 100644 package/grep/0002-sigsegv-fix-build-on-or1k.patch

Comments

Yann E. MORIN Dec. 18, 2021, 1:04 p.m. UTC | #1
Fabrice, All,

On 2021-12-18 11:12 +0100, Fabrice Fontaine spake thusly:
> Fix the following build failure with microblazeel and or1k raised since
> bump to version 3.7 in commit f1f0b633eb1c4bc006b95daad8f299028e89d19d:
> 
> sigsegv.c: In function 'sigsegv_handler':
> sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
>   979 |                       : vma.is_near_this (addr, &vma))
>       |
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/78142463ba8cc5f6c1bf15295095a271422294f4
>  - http://autobuild.buildroot.org/results/f300b1b5e958f096a9d58197a44dcf0c2abd3585
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks. But see below for a little nit...

> ---
>  ...01-sigsegv-fix-build-on-microblazeel.patch | 32 +++++++++++++++++++
>  .../grep/0002-sigsegv-fix-build-on-or1k.patch | 32 +++++++++++++++++++
>  package/grep/grep.mk                          |  2 ++
>  3 files changed, 66 insertions(+)
>  create mode 100644 package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
>  create mode 100644 package/grep/0002-sigsegv-fix-build-on-or1k.patch
> 
> diff --git a/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch b/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
> new file mode 100644
> index 0000000000..4afeb47971
> --- /dev/null
> +++ b/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
> @@ -0,0 +1,32 @@
> +From 3079cea1b18fe72aa1da6b04e561abfb36f4f443 Mon Sep 17 00:00:00 2001
> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +Date: Thu, 11 Nov 2021 09:57:23 +0100
> +Subject: sigsegv: fix build on microblazeel
> +
> +Fix the following build failure on microblazeel with diffutils 3.8:
> +sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
> +http://autobuild.buildroot.org/results/5ecd55b7c72f9630a7acc72341ccb60e94ddb574
> +
> +[Retrieved from:
> +https://git.savannah.gnu.org/cgit/gnulib.git/patch/?id=3079cea1b18fe72aa1da6b04e561abfb36f4f443]
                  ,-----------------------------^^^^^
                 /
I've changed that with s/patch/commit/ so that it points to the nice
html page rather than the raw patch, like is done in the second patch,
below...

> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +---
> + m4/stack-direction.m4 | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/m4/stack-direction.m4 b/m4/stack-direction.m4
> +index c90d69733..70286c8f5 100644
> +--- a/m4/stack-direction.m4
> ++++ b/m4/stack-direction.m4
> +@@ -37,7 +37,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
> +       m68* | \
> +       m88k | \
> +       mcore | \
> +-      microblaze | \
> ++      microblaze* | \
> +       mips* | \
> +       mmix | \
> +       mn10200 | \
> +-- 
> +cgit v1.2.1
> +
> diff --git a/package/grep/0002-sigsegv-fix-build-on-or1k.patch b/package/grep/0002-sigsegv-fix-build-on-or1k.patch
> new file mode 100644
> index 0000000000..73385fe9f7
> --- /dev/null
> +++ b/package/grep/0002-sigsegv-fix-build-on-or1k.patch
> @@ -0,0 +1,32 @@
> +From 496c1740e5475be85b65fdb2b143771f09ed27cb Mon Sep 17 00:00:00 2001
> +From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +Date: Thu, 11 Nov 2021 10:06:31 +0100
> +Subject: sigsegv: fix build on or1k
> +
> +Fix the following build failure on or1k with diffutils 3.8
> +https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=e54aa6196947ed22ff66bcd714e4fc7bd0c5c3b4
> +sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
> +http://autobuild.buildroot.org/results/5427e52489d29ed4f18b4a70b3c36f0f7bb0ddd9
> +
> +[Retrieved from:
> +https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=496c1740e5475be85b65fdb2b143771f09ed27cb]
                                               ,^^^^^^
.. here --------------------------------------ยด

Regards,
Yann E. MORIN.

> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +---
> + m4/stack-direction.m4 | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/m4/stack-direction.m4 b/m4/stack-direction.m4
> +index 70286c8f5..29e398d77 100644
> +--- a/m4/stack-direction.m4
> ++++ b/m4/stack-direction.m4
> +@@ -45,6 +45,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
> +       nios2 | \
> +       nds32* | \
> +       ns32k | \
> ++      or1k | \
> +       pdp11 | \
> +       pj* | \
> +       powerpc* | rs6000 | \
> +-- 
> +cgit v1.2.1
> +
> diff --git a/package/grep/grep.mk b/package/grep/grep.mk
> index 233f5fe633..a485f23dc7 100644
> --- a/package/grep/grep.mk
> +++ b/package/grep/grep.mk
> @@ -10,6 +10,8 @@ GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
>  GREP_LICENSE = GPL-3.0+
>  GREP_LICENSE_FILES = COPYING
>  GREP_CPE_ID_VENDOR = gnu
> +# We're patching m4/stack-direction.m4
> +GREP_AUTORECONF = YES
>  GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
>  # install into /bin like busybox grep
>  GREP_CONF_OPTS = --exec-prefix=/
> -- 
> 2.33.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch b/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
new file mode 100644
index 0000000000..4afeb47971
--- /dev/null
+++ b/package/grep/0001-sigsegv-fix-build-on-microblazeel.patch
@@ -0,0 +1,32 @@ 
+From 3079cea1b18fe72aa1da6b04e561abfb36f4f443 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Thu, 11 Nov 2021 09:57:23 +0100
+Subject: sigsegv: fix build on microblazeel
+
+Fix the following build failure on microblazeel with diffutils 3.8:
+sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
+http://autobuild.buildroot.org/results/5ecd55b7c72f9630a7acc72341ccb60e94ddb574
+
+[Retrieved from:
+https://git.savannah.gnu.org/cgit/gnulib.git/patch/?id=3079cea1b18fe72aa1da6b04e561abfb36f4f443]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ m4/stack-direction.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/m4/stack-direction.m4 b/m4/stack-direction.m4
+index c90d69733..70286c8f5 100644
+--- a/m4/stack-direction.m4
++++ b/m4/stack-direction.m4
+@@ -37,7 +37,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
+       m68* | \
+       m88k | \
+       mcore | \
+-      microblaze | \
++      microblaze* | \
+       mips* | \
+       mmix | \
+       mn10200 | \
+-- 
+cgit v1.2.1
+
diff --git a/package/grep/0002-sigsegv-fix-build-on-or1k.patch b/package/grep/0002-sigsegv-fix-build-on-or1k.patch
new file mode 100644
index 0000000000..73385fe9f7
--- /dev/null
+++ b/package/grep/0002-sigsegv-fix-build-on-or1k.patch
@@ -0,0 +1,32 @@ 
+From 496c1740e5475be85b65fdb2b143771f09ed27cb Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Thu, 11 Nov 2021 10:06:31 +0100
+Subject: sigsegv: fix build on or1k
+
+Fix the following build failure on or1k with diffutils 3.8
+https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=e54aa6196947ed22ff66bcd714e4fc7bd0c5c3b4
+sigsegv.c:979:28: error: 'struct vma_struct' has no member named 'is_near_this'
+http://autobuild.buildroot.org/results/5427e52489d29ed4f18b4a70b3c36f0f7bb0ddd9
+
+[Retrieved from:
+https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=496c1740e5475be85b65fdb2b143771f09ed27cb]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ m4/stack-direction.m4 | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/m4/stack-direction.m4 b/m4/stack-direction.m4
+index 70286c8f5..29e398d77 100644
+--- a/m4/stack-direction.m4
++++ b/m4/stack-direction.m4
+@@ -45,6 +45,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
+       nios2 | \
+       nds32* | \
+       ns32k | \
++      or1k | \
+       pdp11 | \
+       pj* | \
+       powerpc* | rs6000 | \
+-- 
+cgit v1.2.1
+
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index 233f5fe633..a485f23dc7 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -10,6 +10,8 @@  GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPL-3.0+
 GREP_LICENSE_FILES = COPYING
 GREP_CPE_ID_VENDOR = gnu
+# We're patching m4/stack-direction.m4
+GREP_AUTORECONF = YES
 GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 # install into /bin like busybox grep
 GREP_CONF_OPTS = --exec-prefix=/