diff mbox series

Makefile: release: use .tar.xz instead of .tar.bz2

Message ID 20211202170146.20676-1-peter@korsgaard.com
State Accepted
Headers show
Series Makefile: release: use .tar.xz instead of .tar.bz2 | expand

Commit Message

Peter Korsgaard Dec. 2, 2021, 5:01 p.m. UTC
xz compresses better than bzip2, and is (getting) more popular, so build
release tarballs as .tar.xz (in addition to .tar.gz) instead of .tar.bz2,
similar to how the kernel did ~8 years ago:

https://www.kernel.org/happy-new-year-and-good-bye-bzip2.html

-rw-r--r-- 1 peko peko 5,1M Dec  2 17:55 buildroot-2021.11-rc3.tar.xz
-rw-r--r-- 1 peko peko 5,7M Nov 30 18:15 buildroot-2021.11-rc3.tar.bz2
-rw-r--r-- 1 peko peko 6,8M Nov 30 18:15 buildroot-2021.11-rc3.tar.gz

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 3, 2021, 4:42 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > xz compresses better than bzip2, and is (getting) more popular, so build
 > release tarballs as .tar.xz (in addition to .tar.gz) instead of .tar.bz2,
 > similar to how the kernel did ~8 years ago:

 > https://www.kernel.org/happy-new-year-and-good-bye-bzip2.html

 > -rw-r--r-- 1 peko peko 5,1M Dec  2 17:55 buildroot-2021.11-rc3.tar.xz
 > -rw-r--r-- 1 peko peko 5,7M Nov 30 18:15 buildroot-2021.11-rc3.tar.bz2
 > -rw-r--r-- 1 peko peko 6,8M Nov 30 18:15 buildroot-2021.11-rc3.tar.gz

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index 53f6ae9173..0f84122bd3 100644
--- a/Makefile
+++ b/Makefile
@@ -1210,7 +1210,7 @@  release:
 	$(MAKE) O=$(OUT) distclean
 	tar rf $(OUT).tar $(OUT)
 	gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
-	bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
+	xz -9 -c < $(OUT).tar > $(OUT).tar.xz
 	rm -rf $(OUT) $(OUT).tar
 
 print-version: