diff mbox series

[v5,03/10] package/Makefile.in: Fix NOMMU RISC-V 64-bits toolchain base name

Message ID 20211026071728.954356-4-damien.lemoal@wdc.com
State Accepted
Headers show
Series Add RV64 NOMMU and Canaan K210 SoC support | expand

Commit Message

Damien Le Moal Oct. 26, 2021, 7:17 a.m. UTC
From: Christoph Hellwig <hch@lst.de>

Using *-uclinux-* seems like an only partially followed convention.
And at least RISC-V 64-bits gcc does not know about uclinux tuples.
So switch back to the normal "linux" one for now.

Signed-off-by: Christoph Hellwig <hch@lst.de>

[Damien]
* Make the change conditional on BR2_RISCV_64 being "y".

Signed-off-by: Damien Le Moal <damien.lemoal@wdc.com>
---
 package/Makefile.in | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Alistair Francis Oct. 27, 2021, 3:26 a.m. UTC | #1
On Tue, Oct 26, 2021 at 5:25 PM Damien Le Moal <damien.lemoal@wdc.com> wrote:
>
> From: Christoph Hellwig <hch@lst.de>
>
> Using *-uclinux-* seems like an only partially followed convention.
> And at least RISC-V 64-bits gcc does not know about uclinux tuples.
> So switch back to the normal "linux" one for now.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
>
> [Damien]
> * Make the change conditional on BR2_RISCV_64 being "y".
>
> Signed-off-by: Damien Le Moal <damien.lemoal@wdc.com>

Acked-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  package/Makefile.in | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/package/Makefile.in b/package/Makefile.in
> index 04347d2d84..dae7a859fd 100644
> --- a/package/Makefile.in
> +++ b/package/Makefile.in
> @@ -39,8 +39,9 @@ endif
>  # Compute GNU_TARGET_NAME
>  GNU_TARGET_NAME = $(ARCH)-$(TARGET_VENDOR)-$(TARGET_OS)-$(LIBC)$(ABI)
>
> -# FLAT binary format needs uclinux
> -ifeq ($(BR2_BINFMT_FLAT),y)
> +# FLAT binary format needs uclinux, except RISC-V 64-bits which needs
> +# the regular linux name.
> +ifeq ($(BR2_BINFMT_FLAT):$(BR2_RISCV_64),y:)
>  TARGET_OS = uclinux
>  else
>  TARGET_OS = linux
> --
> 2.31.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Oct. 27, 2021, 1:38 p.m. UTC | #2
>>>>> "Damien" == Damien Le Moal <damien.lemoal@wdc.com> writes:

 > From: Christoph Hellwig <hch@lst.de>
 > Using *-uclinux-* seems like an only partially followed convention.
 > And at least RISC-V 64-bits gcc does not know about uclinux tuples.
 > So switch back to the normal "linux" one for now.

 > Signed-off-by: Christoph Hellwig <hch@lst.de>

 > [Damien]
 > * Make the change conditional on BR2_RISCV_64 being "y".

 > Signed-off-by: Damien Le Moal <damien.lemoal@wdc.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/Makefile.in b/package/Makefile.in
index 04347d2d84..dae7a859fd 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -39,8 +39,9 @@  endif
 # Compute GNU_TARGET_NAME
 GNU_TARGET_NAME = $(ARCH)-$(TARGET_VENDOR)-$(TARGET_OS)-$(LIBC)$(ABI)
 
-# FLAT binary format needs uclinux
-ifeq ($(BR2_BINFMT_FLAT),y)
+# FLAT binary format needs uclinux, except RISC-V 64-bits which needs
+# the regular linux name.
+ifeq ($(BR2_BINFMT_FLAT):$(BR2_RISCV_64),y:)
 TARGET_OS = uclinux
 else
 TARGET_OS = linux