diff mbox series

[v2,4/5] boot/grub2/grub2.mk: fix the cdboot.img source from host to target

Message ID 20211022115134.345595-4-kory.maincent@bootlin.com
State Accepted
Headers show
Series [v2,1/5] boot/grub2/grub2.mk: fix the installation of target tools | expand

Commit Message

Kory Maincent Oct. 22, 2021, 11:51 a.m. UTC
This patch updates the location of cdboot.img used, to select the one from
the target directory and not from the host.
The host-grub2 is built only to have access to the Grub tools binaries.

Signed-off-by: Kory Maincent <kory.maincent@bootlin.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
---
 boot/grub2/grub2.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index 19047d02f7..270f289cfd 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -192,7 +192,7 @@  define GRUB2_INSTALL_IMAGES_CMDS
 			$(GRUB2_BUILTIN_MODULES_$(tuple))
 		$(INSTALL) -D -m 0644 boot/grub2/grub.cfg $(GRUB2_CFG_$(tuple))
 		$(if $(findstring $(GRUB2_PLATFORM_$(tuple)), pc), \
-			cat $(HOST_DIR)/lib/grub/$(tuple)/cdboot.img $(GRUB2_IMAGE_$(tuple)) > \
+			cat $(@D)/build-$(tuple)/grub-core/cdboot.img $(GRUB2_IMAGE_$(tuple)) > \
 				$(BINARIES_DIR)/grub-eltorito.img
 		) \
 	)