diff mbox series

package/mstpd: new package

Message ID 20210920192442.2784967-1-francois.perrad@gadz.org
State Accepted
Headers show
Series package/mstpd: new package | expand

Commit Message

Francois Perrad Sept. 20, 2021, 7:24 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 DEVELOPERS               |  1 +
 package/Config.in        |  1 +
 package/mstpd/Config.in  |  9 +++++++++
 package/mstpd/mstpd.hash |  3 +++
 package/mstpd/mstpd.mk   | 13 +++++++++++++
 5 files changed, 27 insertions(+)
 create mode 100644 package/mstpd/Config.in
 create mode 100644 package/mstpd/mstpd.hash
 create mode 100644 package/mstpd/mstpd.mk

Comments

Arnout Vandecappelle Sept. 28, 2021, 8:08 a.m. UTC | #1
On 27/09/2021 10:02, Vadym Kochan wrote:
> 
> Hi All,
> 
> Arnout Vandecappelle <arnout@mind.be> writes:
> 
>>    Hi Francois,
>>
>> On 20/09/2021 21:24, Francois Perrad wrote:
>> [snip]
>>> diff --git a/package/mstpd/mstpd.mk b/package/mstpd/mstpd.mk
>>> new file mode 100644
>>> index 000000000..0e5c9714c
>>> --- /dev/null
>>> +++ b/package/mstpd/mstpd.mk
>>> @@ -0,0 +1,13 @@
>>> +################################################################################
>>> +#
>>> +# mstpd
>>> +#
>>> +################################################################################
>>> +
>>> +MSTPD_VERSION = 0.0.9
>>> +MSTPD_SITE = $(call github,mstpd,mstpd,$(MSTPD_VERSION))
>>> +MSTPD_AUTORECONF = YES
>>> +MSTPD_LICENSE = GPL-2.0
>>
>>    There is actually hmac_md5.c that has a different license. So I added that
>> one, and I added it to LICENSE_FILES as well and to the hash file.
>>
>>> +MSTPD_LICENSE_FILES = LICENSE
>>> +
>>
>>
>>    Vadim (in Cc) posted the same package a year ago. He had
>>
>> +# mstpd requires that it is installed into /sbin, not /usr/sbin
>> +MSTPD_CONF_OPTS = \
>> +	--sbindir=/sbin
>>
>> which he later explained with "it should point to /sbin because
>> Linux's bridge implementation calls /sbin/bridge-stp in case the STP
>> handling is delegated to user space." - which sounds pretty feasible to me...
>>
> 
> This is can be checked at least by this:
> 
>      https://elixir.bootlin.com/linux/v5.15-rc3/source/net/bridge/br_private.h#L51
> 
> So may be just create /sbin/bridge-stp link.

  I think the --sbindir approach is cleaner. Although I see that openwrt in fact 
uses custom install commands and puts mstpd and mstpctl in /usr/sbin, and 
bridge-stp in /sbin.

  Also note that a symlink is tricky in the unified /usr case, because then 
/sbin/bridge-stp and /usr/sbin/bridge-stp are the same file.

  Regards,
  Arnout

>>    Did you test this with STP and with a non-unified /usr?
>>
>>    I've anyway alreayd applied as-is to master (with the license fix), but please
>> check if the --sbindir is needed.
>>
>>    Regards,
>>    Arnout
>>
>>> +$(eval $(autotools-package))
>>>
>> _______________________________________________
>> buildroot mailing list
>> buildroot@buildroot.org
>> https://lists.buildroot.org/mailman/listinfo/buildroot
>
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 50e36de39..d8d077e51 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -967,6 +967,7 @@  F:	package/lsqlite3/
 F:	package/lua*
 F:	package/lzlib/
 F:	package/moarvm/
+F:	package/mstpd/
 F:	package/netsurf/
 F:	package/perl*
 F:	package/pkg-perl.mk
diff --git a/package/Config.in b/package/Config.in
index 4d323d440..5f4960bce 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2208,6 +2208,7 @@  menu "Networking applications"
 	source "package/mosquitto/Config.in"
 	source "package/mrouted/Config.in"
 	source "package/mrp/Config.in"
+	source "package/mstpd/Config.in"
 	source "package/mtr/Config.in"
 	source "package/nbd/Config.in"
 	source "package/ncftp/Config.in"
diff --git a/package/mstpd/Config.in b/package/mstpd/Config.in
new file mode 100644
index 000000000..5fe585977
--- /dev/null
+++ b/package/mstpd/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_MSTPD
+	bool "mstpd"
+	help
+	  Multiple Spanning Tree Protocol Daemon.
+	  This package provides a user-space daemon which replaces
+	  the STP handling that is built into the Linux kernel Ethernet
+	  bridge and adds support for RSTP and PVST+.
+
+	  https://github.com/mstpd/mstpd
diff --git a/package/mstpd/mstpd.hash b/package/mstpd/mstpd.hash
new file mode 100644
index 000000000..7fb88c898
--- /dev/null
+++ b/package/mstpd/mstpd.hash
@@ -0,0 +1,3 @@ 
+# locally computed
+sha256  91a1862548b5b509caa2e96e5fb9912bc98d4d58cc98e99a577824735756c14d  mstpd-0.0.9.tar.gz
+sha256  c38aee9e3c8c4d5d594ff548a1be05453023016d6286931f6512db215ec1fd42  LICENSE
diff --git a/package/mstpd/mstpd.mk b/package/mstpd/mstpd.mk
new file mode 100644
index 000000000..0e5c9714c
--- /dev/null
+++ b/package/mstpd/mstpd.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# mstpd
+#
+################################################################################
+
+MSTPD_VERSION = 0.0.9
+MSTPD_SITE = $(call github,mstpd,mstpd,$(MSTPD_VERSION))
+MSTPD_AUTORECONF = YES
+MSTPD_LICENSE = GPL-2.0
+MSTPD_LICENSE_FILES = LICENSE
+
+$(eval $(autotools-package))