diff mbox series

[2/3] toolchain/toolchain-wrapper: use Gcc bug 97208 instead of repeating it

Message ID 20210813213745.1555522-3-giulio.benetti@benettiengineering.com
State Rejected
Headers show
Series Microblaze gcc bug 97208 | expand

Commit Message

Giulio Benetti Aug. 13, 2021, 9:37 p.m. UTC
Now that we have added Gcc bug 97208 we can use it instead of repeating it.
So let's substitute bug condition with bug presence. Also note that gcc bug
97208 is still present in gcc 11.1.0 so better to make comment more generic
and keep a detailed description in toolchain/Config.in

Cc: Roman Naour <romain.naour@gmail.com>
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 toolchain/toolchain-wrapper.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Giulio Benetti Aug. 14, 2021, 10:11 p.m. UTC | #1
Please drop this patch, I've already set it as Rejected in Patchwork.
Sorry for the noise
diff mbox series

Patch

diff --git a/toolchain/toolchain-wrapper.mk b/toolchain/toolchain-wrapper.mk
index 8b551e3a18..c56ec7c054 100644
--- a/toolchain/toolchain-wrapper.mk
+++ b/toolchain/toolchain-wrapper.mk
@@ -33,11 +33,10 @@  TOOLCHAIN_WRAPPER_OPTS += -DBR_NEED_SOURCE_DATE_EPOCH
 endif
 endif
 
-# Disable -ftree-loop-distribute-patterns on microblaze to
-# workaround a compiler bug with gcc 10 and -O2, -Os or -O3.
+# Disable -ftree-loop-distribute-patterns on compiler affected by gcc bug 97208.
 # https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=5879ab5fafedc8f6f9bfe95a4cf8501b0df90edd
 # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=97208
-ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_10)$(BR2_microblaze),yy)
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_97208),y)
 TOOLCHAIN_WRAPPER_OPTS += -fno-tree-loop-distribute-patterns
 endif