diff mbox series

package/glibc: Use 2.33 for RISC-V 32-bit

Message ID 20210806003144.455964-1-joel@jms.id.au
State Accepted
Headers show
Series package/glibc: Use 2.33 for RISC-V 32-bit | expand

Commit Message

Joel Stanley Aug. 6, 2021, 12:31 a.m. UTC
RISC-V 32-bit was special cased to use glibc master as support was not
in a released version.

Recently 2.33 was released, so RV32 can now use the same glibc version
as other platforms.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
I was adding some glibc patches and was confused by the version
situation. I think this was overlooked when bumping the version to 2.33.

I built qemu_riscv32_virt_defconfig and boot tested this in qemu:

# /lib/ld-linux-riscv32-ilp32d.so.1 --version
ld.so (Buildroot) release release version 2.33.

 .../glibc.hash                                             | 7 -------
 package/glibc/glibc.mk                                     | 6 ------
 2 files changed, 13 deletions(-)
 delete mode 100644 package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash

Comments

Alistair Francis Aug. 6, 2021, 12:48 a.m. UTC | #1
On Fri, Aug 6, 2021 at 10:32 AM Joel Stanley <joel@jms.id.au> wrote:
>
> RISC-V 32-bit was special cased to use glibc master as support was not
> in a released version.
>
> Recently 2.33 was released, so RV32 can now use the same glibc version
> as other platforms.
>
> Signed-off-by: Joel Stanley <joel@jms.id.au>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
> I was adding some glibc patches and was confused by the version
> situation. I think this was overlooked when bumping the version to 2.33.
>
> I built qemu_riscv32_virt_defconfig and boot tested this in qemu:
>
> # /lib/ld-linux-riscv32-ilp32d.so.1 --version
> ld.so (Buildroot) release release version 2.33.
>
>  .../glibc.hash                                             | 7 -------
>  package/glibc/glibc.mk                                     | 6 ------
>  2 files changed, 13 deletions(-)
>  delete mode 100644 package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
>
> diff --git a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash b/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
> deleted file mode 100644
> index 558591522e3a..000000000000
> --- a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
> +++ /dev/null
> @@ -1,7 +0,0 @@
> -# Locally calculated (fetched from Github)
> -sha256 c3828224d69a42f5b6982cbec8ae01cf494fe975ce9023e36ff2c10a2fb93e42 glibc-2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99.tar.gz
> -
> -# Hashes for license files
> -sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
> -sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
> -sha256  b33d0bd9f685b46853548814893a6135e74430d12f6d94ab3eba42fc591f83bc  LICENSES
> diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
> index 1c8c40987812..1eff2455881d 100644
> --- a/package/glibc/glibc.mk
> +++ b/package/glibc/glibc.mk
> @@ -11,13 +11,7 @@ else
>  # Generate version string using:
>  #   git describe --match 'glibc-*' --abbrev=40 origin/release/MAJOR.MINOR/master | cut -d '-' -f 2-
>  # When updating the version, please also update localedef
> -ifeq ($(BR2_RISCV_32),y)
> -# RISC-V 32-bit (RV32) requires glibc 2.33 or newer
> -# Until 2.33 is released, just use master
> -GLIBC_VERSION = 2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99
> -else
>  GLIBC_VERSION = 2.33-46-gedfd11197ecf3629bbb4b66c5814da09a61a7f9f
> -endif
>  # Upstream doesn't officially provide an https download link.
>  # There is one (https://sourceware.org/git/glibc.git) but it's not reliable,
>  # sometimes the connection times out. So use an unofficial github mirror.
> --
> 2.32.0
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN Aug. 7, 2021, 10 a.m. UTC | #2
Joel, All,

On 2021-08-06 10:01 +0930, Joel Stanley spake thusly:
> RISC-V 32-bit was special cased to use glibc master as support was not
> in a released version.
> 
> Recently 2.33 was released, so RV32 can now use the same glibc version
> as other platforms.
> 
> Signed-off-by: Joel Stanley <joel@jms.id.au>

Although we're in release-freeze, we've still considered whether it made
sense to have this on master, and with Thomas and Peter, we concluded
that this was indeed better.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> I was adding some glibc patches and was confused by the version
> situation. I think this was overlooked when bumping the version to 2.33.
> 
> I built qemu_riscv32_virt_defconfig and boot tested this in qemu:
> 
> # /lib/ld-linux-riscv32-ilp32d.so.1 --version
> ld.so (Buildroot) release release version 2.33.
> 
>  .../glibc.hash                                             | 7 -------
>  package/glibc/glibc.mk                                     | 6 ------
>  2 files changed, 13 deletions(-)
>  delete mode 100644 package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
> 
> diff --git a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash b/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
> deleted file mode 100644
> index 558591522e3a..000000000000
> --- a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
> +++ /dev/null
> @@ -1,7 +0,0 @@
> -# Locally calculated (fetched from Github)
> -sha256 c3828224d69a42f5b6982cbec8ae01cf494fe975ce9023e36ff2c10a2fb93e42 glibc-2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99.tar.gz
> -
> -# Hashes for license files
> -sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
> -sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
> -sha256  b33d0bd9f685b46853548814893a6135e74430d12f6d94ab3eba42fc591f83bc  LICENSES
> diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
> index 1c8c40987812..1eff2455881d 100644
> --- a/package/glibc/glibc.mk
> +++ b/package/glibc/glibc.mk
> @@ -11,13 +11,7 @@ else
>  # Generate version string using:
>  #   git describe --match 'glibc-*' --abbrev=40 origin/release/MAJOR.MINOR/master | cut -d '-' -f 2-
>  # When updating the version, please also update localedef
> -ifeq ($(BR2_RISCV_32),y)
> -# RISC-V 32-bit (RV32) requires glibc 2.33 or newer
> -# Until 2.33 is released, just use master
> -GLIBC_VERSION = 2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99
> -else
>  GLIBC_VERSION = 2.33-46-gedfd11197ecf3629bbb4b66c5814da09a61a7f9f
> -endif
>  # Upstream doesn't officially provide an https download link.
>  # There is one (https://sourceware.org/git/glibc.git) but it's not reliable,
>  # sometimes the connection times out. So use an unofficial github mirror.
> -- 
> 2.32.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash b/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
deleted file mode 100644
index 558591522e3a..000000000000
--- a/package/glibc/2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99/glibc.hash
+++ /dev/null
@@ -1,7 +0,0 @@ 
-# Locally calculated (fetched from Github)
-sha256 c3828224d69a42f5b6982cbec8ae01cf494fe975ce9023e36ff2c10a2fb93e42 glibc-2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99.tar.gz
-
-# Hashes for license files
-sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
-sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
-sha256  b33d0bd9f685b46853548814893a6135e74430d12f6d94ab3eba42fc591f83bc  LICENSES
diff --git a/package/glibc/glibc.mk b/package/glibc/glibc.mk
index 1c8c40987812..1eff2455881d 100644
--- a/package/glibc/glibc.mk
+++ b/package/glibc/glibc.mk
@@ -11,13 +11,7 @@  else
 # Generate version string using:
 #   git describe --match 'glibc-*' --abbrev=40 origin/release/MAJOR.MINOR/master | cut -d '-' -f 2-
 # When updating the version, please also update localedef
-ifeq ($(BR2_RISCV_32),y)
-# RISC-V 32-bit (RV32) requires glibc 2.33 or newer
-# Until 2.33 is released, just use master
-GLIBC_VERSION = 2.32.9000-69-gbd394d131c10c9ec22c6424197b79410042eed99
-else
 GLIBC_VERSION = 2.33-46-gedfd11197ecf3629bbb4b66c5814da09a61a7f9f
-endif
 # Upstream doesn't officially provide an https download link.
 # There is one (https://sourceware.org/git/glibc.git) but it's not reliable,
 # sometimes the connection times out. So use an unofficial github mirror.