diff mbox series

boot/at91bootstrap3: updated to released 4.0.0 final version

Message ID 20210730103908.11270-1-eugen.hristev@microchip.com
State Changes Requested
Headers show
Series boot/at91bootstrap3: updated to released 4.0.0 final version | expand

Commit Message

Eugen Hristev July 30, 2021, 10:39 a.m. UTC
Update to AT91Bootstrap 4.0.0 version.

This package is now released under MIT license.

Signed-off-by: Eugen Hristev <eugen.hristev@microchip.com>
---
 boot/at91bootstrap3/Config.in           | 4 ++--
 boot/at91bootstrap3/at91bootstrap3.hash | 2 +-
 boot/at91bootstrap3/at91bootstrap3.mk   | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni July 30, 2021, 9:42 p.m. UTC | #1
Hello Eugen,

On Fri, 30 Jul 2021 13:39:08 +0300
Eugen Hristev via buildroot <buildroot@busybox.net> wrote:

> Update to AT91Bootstrap 4.0.0 version.
> 
> This package is now released under MIT license.
> 
> Signed-off-by: Eugen Hristev <eugen.hristev@microchip.com>

Thanks for the patch.

> -AT91BOOTSTRAP3_LICENSE = Atmel License
> +AT91BOOTSTRAP3_LICENSE = MIT

While this change is correct for at91bootstrap 4.x, I don't think it's
true for at91bootstrap 3.x, so I suppose this should instead be
conditional?

The problem is... what should be the condition? Indeed, testing on
BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION vs.
BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X is not working, because the
user can specify a custom Git or a custom tarball, and there we don't
know what version is used (3.x of 4.x).

I must admit I don't have a good idea here.

Best regards,

Thomas
Yann E. MORIN July 31, 2021, 7:11 a.m. UTC | #2
Thomas, Eugen, All,

On 2021-07-30 23:42 +0200, Thomas Petazzoni spake thusly:
> On Fri, 30 Jul 2021 13:39:08 +0300
> Eugen Hristev via buildroot <buildroot@busybox.net> wrote:
> > Update to AT91Bootstrap 4.0.0 version.
> > This package is now released under MIT license.
> > Signed-off-by: Eugen Hristev <eugen.hristev@microchip.com>
> > -AT91BOOTSTRAP3_LICENSE = Atmel License
> > +AT91BOOTSTRAP3_LICENSE = MIT
> 
> While this change is correct for at91bootstrap 4.x, I don't think it's
> true for at91bootstrap 3.x, so I suppose this should instead be
> conditional?
> 
> The problem is... what should be the condition? Indeed, testing on
> BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION vs.
> BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X is not working, because the
> user can specify a custom Git or a custom tarball, and there we don't
> know what version is used (3.x of 4.x).
> 
> I must admit I don't have a good idea here.

This is exactly what we do in the other packages in that situation: for
known versions, we define the appropriate licensing terms, and for
custom versions, we define nothing. See for example:

    boot/barebox            only license file is conditional
    boot/uboot              both licensing terms and license file are conditional
    boot/optee-os           only license file is conditional
    linux                   only license file is conditional

And a few others I have forgotten.

So in this case, we'd hav something like:

    ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION),y)
    AT91BOOTSTRAP3_LICENSE = MIT
    else ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X),y)
    AT91BOOTSTRAP3_LICENSE = Atmel License
    endif

Regards,
Yann E. MORIN.
Thomas Petazzoni July 31, 2021, 8:14 a.m. UTC | #3
On Sat, 31 Jul 2021 09:11:29 +0200
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> So in this case, we'd hav something like:
> 
>     ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION),y)
>     AT91BOOTSTRAP3_LICENSE = MIT
>     else ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X),y)
>     AT91BOOTSTRAP3_LICENSE = Atmel License
>     endif

Indeed, sounds good.

Thomas
Voss, Samuel M Collins via buildroot Aug. 2, 2021, 6:57 a.m. UTC | #4
On 7/31/21 12:42 AM, Thomas Petazzoni wrote:
> Hello Eugen,
> 
> On Fri, 30 Jul 2021 13:39:08 +0300
> Eugen Hristev via buildroot <buildroot@busybox.net> wrote:
> 
>> Update to AT91Bootstrap 4.0.0 version.
>>
>> This package is now released under MIT license.
>>
>> Signed-off-by: Eugen Hristev <eugen.hristev@microchip.com>
> 
> Thanks for the patch.
> 
>> -AT91BOOTSTRAP3_LICENSE = Atmel License
>> +AT91BOOTSTRAP3_LICENSE = MIT
> 
> While this change is correct for at91bootstrap 4.x, I don't think it's
> true for at91bootstrap 3.x, so I suppose this should instead be
> conditional?

Hi Thomas,

The plan is to also switch at91bootstrap3 to the same license.
So if you want, you can hold the patch until I update bootstrap3 as well.

Eugen

> 
> The problem is... what should be the condition? Indeed, testing on
> BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION vs.
> BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X is not working, because the
> user can specify a custom Git or a custom tarball, and there we don't
> know what version is used (3.x of 4.x).
> 
> I must admit I don't have a good idea here.
> 
> Best regards,
> 
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
>
Yann E. MORIN Aug. 2, 2021, 4:37 p.m. UTC | #5
Eugen, All,

On 2021-08-02 06:57 +0000, Eugen.Hristev@microchip.com spake thusly:
> On 7/31/21 12:42 AM, Thomas Petazzoni wrote:
> > On Fri, 30 Jul 2021 13:39:08 +0300
> > Eugen Hristev via buildroot <buildroot@busybox.net> wrote:
> >> Update to AT91Bootstrap 4.0.0 version.
> >> This package is now released under MIT license.
> >> -AT91BOOTSTRAP3_LICENSE = Atmel License
> >> +AT91BOOTSTRAP3_LICENSE = MIT
> > While this change is correct for at91bootstrap 4.x, I don't think it's
> > true for at91bootstrap 3.x, so I suppose this should instead be
> > conditional?
> The plan is to also switch at91bootstrap3 to the same license.
> So if you want, you can hold the patch until I update bootstrap3 as well.

The problem will remain for custom versions. Indeed, users can select
any arbitrary git tree and git commit, and for those, we have no way to
know whether they are from before or after the change in licensing
terms.

As such, we will still want to have a conditional block, like I proposed
as a reply to Thomas.

Regards,
Yann E. MORIN.
Voss, Samuel M Collins via buildroot Aug. 3, 2021, 8:26 a.m. UTC | #6
On 7/31/21 11:14 AM, Thomas Petazzoni wrote:
> On Sat, 31 Jul 2021 09:11:29 +0200
> "Yann E. MORIN" <yann.morin.1998@free.fr> wrote:
> 
>> So in this case, we'd hav something like:
>>
>>      ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION),y)
>>      AT91BOOTSTRAP3_LICENSE = MIT
>>      else ifeq ($(BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X),y)
>>      AT91BOOTSTRAP3_LICENSE = Atmel License
>>      endif
> 
> Indeed, sounds good.

Hi,

Do you want me to update the patch with this or you want to change it 
when applying ?

Eugen

> 
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
>
diff mbox series

Patch

diff --git a/boot/at91bootstrap3/Config.in b/boot/at91bootstrap3/Config.in
index f44597bc00..f459b8d7c0 100644
--- a/boot/at91bootstrap3/Config.in
+++ b/boot/at91bootstrap3/Config.in
@@ -19,7 +19,7 @@  choice
 	prompt "AT91 Bootstrap 3+ version"
 
 config BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION
-	bool "4.0.0-rc2"
+	bool "4.0.0"
 
 config BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X
 	bool "3.10.2"
@@ -54,7 +54,7 @@  endif
 
 config BR2_TARGET_AT91BOOTSTRAP3_VERSION
 	string
-	default "v4.0.0-rc2" if BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION
+	default "v4.0.0" if BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION
 	default "v3.10.2" if BR2_TARGET_AT91BOOTSTRAP3_LATEST_VERSION_3X
 	default BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_REPO_VERSION \
 		if BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_GIT
diff --git a/boot/at91bootstrap3/at91bootstrap3.hash b/boot/at91bootstrap3/at91bootstrap3.hash
index 8b7453bbd4..7092a4f28b 100644
--- a/boot/at91bootstrap3/at91bootstrap3.hash
+++ b/boot/at91bootstrap3/at91bootstrap3.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
 sha256  33e4ba431af93a4fc2e81c1458cd31901b9f69c583ebe4c74ca78c0846479bfd  at91bootstrap3-v3.10.2.tar.gz
-sha256  b5d5f042297cad0d091f7d8734e61eb9ec7b6020898e086503fb5f8bc71fb9fc  at91bootstrap3-v4.0.0-rc2.tar.gz
+sha256  08c5b95df28be7f2e0439fb2b77fe27524f97c499850641e4540c07ea0b2c25d  at91bootstrap3-v4.0.0.tar.gz
diff --git a/boot/at91bootstrap3/at91bootstrap3.mk b/boot/at91bootstrap3/at91bootstrap3.mk
index b253129dfb..aec909cfd8 100644
--- a/boot/at91bootstrap3/at91bootstrap3.mk
+++ b/boot/at91bootstrap3/at91bootstrap3.mk
@@ -19,7 +19,7 @@  else
 AT91BOOTSTRAP3_SITE = $(call github,linux4sam,at91bootstrap,$(AT91BOOTSTRAP3_VERSION))
 endif
 
-AT91BOOTSTRAP3_LICENSE = Atmel License
+AT91BOOTSTRAP3_LICENSE = MIT
 
 AT91BOOTSTRAP3_CPE_ID_VENDOR = linux4sam
 AT91BOOTSTRAP3_CPE_ID_PRODUCT = at91bootstrap