diff mbox series

[v2,3/5] package/nginx-naxsi: bump version to 1.3

Message ID 20210630173700.30975-4-aduskett@gmail.com
State Accepted
Headers show
Series nginx updates | expand

Commit Message

Adam Duskett June 30, 2021, 5:36 p.m. UTC
Other changes:
  - Change license to GPL-3.0 and BSD-3c
  - Change license file to LICENSE and naxsi_src/ext/libinjection/COPYING
  - Update license hash's in nginx-naxsi.hash

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
Changes v1 -> v2:
  - Add pcre as a dependency (Yann)
  - Add naxsi_src/ext/libinjection/COPYING license file (Yann)
  - Drop "with OpenSSL exception" (yann)

 package/nginx-naxsi/nginx-naxsi.hash | 5 +++--
 package/nginx-naxsi/nginx-naxsi.mk   | 8 +++++---
 2 files changed, 8 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni July 20, 2021, 10 p.m. UTC | #1
Hello Adam,

+Yann in Cc.

On Wed, 30 Jun 2021 10:36:58 -0700
Adam Duskett <aduskett@gmail.com> wrote:

> -NGINX_NAXSI_VERSION = 0.56
> +NGINX_NAXSI_VERSION = 1.3
>  NGINX_NAXSI_SITE = $(call github,nbs-system,naxsi,$(NGINX_NAXSI_VERSION))
> -NGINX_NAXSI_LICENSE = GPL-2.0+ with OpenSSL exception
> -NGINX_NAXSI_LICENSE_FILES = naxsi_src/naxsi_json.c
> +NGINX_NAXSI_LICENSE = GPL-3.0 BSD-3c

This was not quite correct: it should be comma-separated, and the SPDX
identifier for BSD-3c is BSD-3-Clause. So I changed this line to:

NGINX_NAXSI_LICENSE = GPL-3.0, BSD-3-Clause (libinjection)

> +NGINX_NAXSI_LICENSE_FILES = LICENSE naxsi_src/ext/libinjection/COPYING
> +NGINX_NAXSI_DEPENDENCIES = pcre

And also I think this new pcre dependency is not really correct. Yes,
the Config.in files selects BR2_PACKAGE_PCRE, but it doesn't mean
nginx-naxsi has a build dependency on pcre. In fact, nginx-naxsi
doesn't build anything, it only downloads code, and it's really nginx
that builds these external modules.

This was already discussed in 2016 when Samuel Martin added the
BR2_PACKAGE_PCRE select. See:

  http://lists.busybox.net/pipermail/buildroot/2016-September/172028.html
  http://lists.busybox.net/pipermail/buildroot/2016-September/172171.html

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/nginx-naxsi/nginx-naxsi.hash b/package/nginx-naxsi/nginx-naxsi.hash
index 1f289c56cd..4712ede2af 100644
--- a/package/nginx-naxsi/nginx-naxsi.hash
+++ b/package/nginx-naxsi/nginx-naxsi.hash
@@ -1,3 +1,4 @@ 
 # Locally calculated
-sha256	0a66dcadd32432460fab180be9f2efe24e911e3798917b2787ee710e02901eb4	nginx-naxsi-0.56.tar.gz
-sha256	046812ddc8f250f85b5d6e04218c185849c618b309271ef9d8b01e92c6f7a6ac	naxsi_src/naxsi_json.c
+sha256  439c8677372d2597b4360bbcc10bc86490de1fc75695b193ad5df154a214d628  nginx-naxsi-1.3.tar.gz
+sha256  589ed823e9a84c56feb95ac58e7cf384626b9cbf4fda2a907bc36e103de1bad2  LICENSE
+sha256  d0732bc23658db5b9749e3f9cd4fe0f9b3e132b5955adccb08821845fe2a21c8  naxsi_src/ext/libinjection/COPYING
diff --git a/package/nginx-naxsi/nginx-naxsi.mk b/package/nginx-naxsi/nginx-naxsi.mk
index 7cfa94a5d4..c599ebf3be 100644
--- a/package/nginx-naxsi/nginx-naxsi.mk
+++ b/package/nginx-naxsi/nginx-naxsi.mk
@@ -4,9 +4,11 @@ 
 #
 ################################################################################
 
-NGINX_NAXSI_VERSION = 0.56
+NGINX_NAXSI_VERSION = 1.3
 NGINX_NAXSI_SITE = $(call github,nbs-system,naxsi,$(NGINX_NAXSI_VERSION))
-NGINX_NAXSI_LICENSE = GPL-2.0+ with OpenSSL exception
-NGINX_NAXSI_LICENSE_FILES = naxsi_src/naxsi_json.c
+NGINX_NAXSI_LICENSE = GPL-3.0 BSD-3c
+NGINX_NAXSI_LICENSE_FILES = LICENSE naxsi_src/ext/libinjection/COPYING
+NGINX_NAXSI_DEPENDENCIES = pcre
+
 
 $(eval $(generic-package))