diff mbox series

[1/2] package/usbguard: improve option handling

Message ID 20210623165924.200759-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/usbguard: improve option handling | expand

Commit Message

Fabrice Fontaine June 23, 2021, 4:59 p.m. UTC
Don't pass --disable-seccomp and --disable-systemd unconditionally
While at it, also add a space and a new line when needed

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/usbguard/usbguard.mk | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni June 26, 2021, 1:07 p.m. UTC | #1
On Wed, 23 Jun 2021 18:59:23 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Don't pass --disable-seccomp and --disable-systemd unconditionally
> While at it, also add a space and a new line when needed
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/usbguard/usbguard.mk | 10 ++++++++--
>  1 file changed, 8 insertions(+), 2 deletions(-)

Thanks, I've applied both patches. For this one, I also took this
opportunity to split the initial CONF_OPTS assignment to have one
option per line, each indented with one tab.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/usbguard/usbguard.mk b/package/usbguard/usbguard.mk
index 72e9e6459a..3aff254b3e 100644
--- a/package/usbguard/usbguard.mk
+++ b/package/usbguard/usbguard.mk
@@ -8,9 +8,9 @@  USBGUARD_VERSION = 1.0.0
 USBGUARD_SITE = https://github.com/USBGuard/usbguard/releases/download/usbguard-$(USBGUARD_VERSION)
 USBGUARD_LICENSE = GPL-2.0+
 USBGUARD_LICENSE_FILES = LICENSE
-USBGUARD_CONF_OPTS= --with-bundled-catch --with-bundled-pegtl \
+USBGUARD_CONF_OPTS = --with-bundled-catch --with-bundled-pegtl \
 		    --disable-debug-build --without-dbus --without-polkit \
-		    --disable-seccomp --disable-umockdev --disable-systemd
+		    --disable-umockdev
 
 USBGUARD_DEPENDENCIES += libqb protobuf
 
@@ -18,10 +18,12 @@  ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
 USBGUARD_CONF_OPTS += --with-crypto-library=openssl
 USBGUARD_DEPENDENCIES += libopenssl
 endif
+
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 USBGUARD_CONF_OPTS += --with-crypto-library=gcrypt
 USBGUARD_DEPENDENCIES += libgcrypt
 endif
+
 ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
 USBGUARD_CONF_OPTS += --with-crypto-library=sodium
 USBGUARD_DEPENDENCIES += libsodium
@@ -30,11 +32,15 @@  endif
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 USBGUARD_CONF_OPTS += --enable-systemd
 USBGUARD_DEPENDENCIES += systemd
+else
+USBGUARD_CONF_OPTS += --disable-systemd
 endif
 
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
 USBGUARD_CONF_OPTS += --enable-seccomp
 USBGUARD_DEPENDENCIES += libseccomp
+else
+USBGUARD_CONF_OPTS += --disable-seccomp
 endif
 
 ifeq ($(BR2_PACKAGE_LIBCAP_NG),y)