diff mbox series

package/gawk: create awk symlink for host-gawk

Message ID 20210615140302.2485993-1-hubert.lacote@gmail.com
State Accepted
Headers show
Series package/gawk: create awk symlink for host-gawk | expand

Commit Message

Hubert Lacote June 15, 2021, 2:03 p.m. UTC
From: Hubert Lacote <hubert.lacote@youview.com>

This is to make sure that host packages that depend on `host-gawk` and that use
`awk` end up using `gawk`, instead of the `awk` symlink installed on the host
system.

On recent Debian-based distributions, `awk` is still symlinked to `mawk` [1].

[1] https://bugs.launchpad.net/ubuntu/+source/mawk/+bug/1841654

Signed-off-by: Hubert Lacote <hubert.lacote@youview.com>
Co-authored-by: Hubert Lacote <hubert.lacote@youview.com>
Co-authored-by: Vicente Olivert Riera <vincent.olivert.riera@youview.com>
---
 package/gawk/gawk.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Yann E. MORIN June 24, 2021, 9:38 p.m. UTC | #1
Hubert, All,

On 2021-06-15 16:03 +0200, Hubert Lacote spake thusly:
> From: Hubert Lacote <hubert.lacote@youview.com>
> 
> This is to make sure that host packages that depend on `host-gawk` and that use
> `awk` end up using `gawk`, instead of the `awk` symlink installed on the host
> system.
> 
> On recent Debian-based distributions, `awk` is still symlinked to `mawk` [1].
> 
> [1] https://bugs.launchpad.net/ubuntu/+source/mawk/+bug/1841654
> 
> Signed-off-by: Hubert Lacote <hubert.lacote@youview.com>
> Co-authored-by: Hubert Lacote <hubert.lacote@youview.com>
> Co-authored-by: Vicente Olivert Riera <vincent.olivert.riera@youview.com>
> ---
>  package/gawk/gawk.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/package/gawk/gawk.mk b/package/gawk/gawk.mk
> index 16906f6f93..ab7088e90e 100644
> --- a/package/gawk/gawk.mk
> +++ b/package/gawk/gawk.mk
> @@ -33,6 +33,12 @@ endif
>  
>  HOST_GAWK_CONF_OPTS = --without-readline --without-mpfr
>  
> +define HOST_GAWK_CREATE_SYMLINK
> +	ln -sf gawk $(HOST_DIR)/usr/bin/awk
> +endef
> +
> +HOST_GAWK_POST_INSTALL_HOOKS += HOST_GAWK_CREATE_SYMLINK

Usually, we add the host-variant stuff after the target-variant stuff,
so I moved that after the corresponding hook, below:

>  define GAWK_CREATE_SYMLINK
>  	ln -sf gawk $(TARGET_DIR)/usr/bin/awk
>  endef

Of course, I see that you inserted that next to the existing
host-variant CONF_OPTS, and I can see the reasoning. Still, I found it
odd for the host suff to be stuffed in the middle of the tarrget
stuff...

Applied to master, thanks.

Regards,
Yann E. MORIN.

> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard July 10, 2021, 5:22 p.m. UTC | #2
>>>>> "Hubert" == Hubert Lacote <hubert.lacote@gmail.com> writes:

 > From: Hubert Lacote <hubert.lacote@youview.com>
 > This is to make sure that host packages that depend on `host-gawk` and that use
 > `awk` end up using `gawk`, instead of the `awk` symlink installed on the host
 > system.

 > On recent Debian-based distributions, `awk` is still symlinked to `mawk` [1].

 > [1] https://bugs.launchpad.net/ubuntu/+source/mawk/+bug/1841654

 > Signed-off-by: Hubert Lacote <hubert.lacote@youview.com>
 > Co-authored-by: Hubert Lacote <hubert.lacote@youview.com>
 > Co-authored-by: Vicente Olivert Riera <vincent.olivert.riera@youview.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/gawk/gawk.mk b/package/gawk/gawk.mk
index 16906f6f93..ab7088e90e 100644
--- a/package/gawk/gawk.mk
+++ b/package/gawk/gawk.mk
@@ -33,6 +33,12 @@  endif
 
 HOST_GAWK_CONF_OPTS = --without-readline --without-mpfr
 
+define HOST_GAWK_CREATE_SYMLINK
+	ln -sf gawk $(HOST_DIR)/usr/bin/awk
+endef
+
+HOST_GAWK_POST_INSTALL_HOOKS += HOST_GAWK_CREATE_SYMLINK
+
 define GAWK_CREATE_SYMLINK
 	ln -sf gawk $(TARGET_DIR)/usr/bin/awk
 endef