diff mbox series

[5/9] package/protobuf: fix build failure due to missing -mcmodel=large

Message ID 20210503111350.2933319-6-giulio.benetti@benettiengineering.com
State Changes Requested
Headers show
Series Fix binutils bug 21464 and remove it | expand

Commit Message

Giulio Benetti May 3, 2021, 11:13 a.m. UTC
When building protobuf for or1k -mcmodel=large is needed to link, so let's
add that gcc option in case we're building for or1k.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/protobuf/protobuf.mk | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
index ea75480038..d6b3557020 100644
--- a/package/protobuf/protobuf.mk
+++ b/package/protobuf/protobuf.mk
@@ -24,6 +24,10 @@  ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
 PROTOBUF_CXXFLAGS += -O0
 endif
 
+ifeq ($(BR2_or1k),y)
+PROTOBUF_CXXFLAGS += -mcmodel=large
+endif
+
 PROTOBUF_CONF_ENV = CXXFLAGS="$(PROTOBUF_CXXFLAGS)"
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)