diff mbox series

[3/3] package/mkpimage: define extract step to allow patching

Message ID 20210426214628.20941-3-peter@korsgaard.com
State Accepted
Headers show
Series [1/3] package/makedevs: define extract step to allow patching | expand

Commit Message

Peter Korsgaard April 26, 2021, 9:46 p.m. UTC
As recently discussed on the list:
http://lists.busybox.net/pipermail/buildroot/2021-April/308373.html

Packages like mkpimage where the source code is included in the Buildroot
tree, currently doesn't use an extract step (which also skips the patch
step), so they cannot be patched by a patch in BR2_GLOBAL_PATCH_DIR (or the
pkgdir), which is a bit confusing.

As a fix, add a simple extract step that copies the source file to the build
directory, so the patch step gets run as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/mkpimage/mkpimage.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard April 28, 2021, 9:44 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > As recently discussed on the list:
 > http://lists.busybox.net/pipermail/buildroot/2021-April/308373.html

 > Packages like mkpimage where the source code is included in the Buildroot
 > tree, currently doesn't use an extract step (which also skips the patch
 > step), so they cannot be patched by a patch in BR2_GLOBAL_PATCH_DIR (or the
 > pkgdir), which is a bit confusing.

 > As a fix, add a simple extract step that copies the source file to the build
 > directory, so the patch step gets run as well.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard May 1, 2021, 12:17 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > As recently discussed on the list:
 > http://lists.busybox.net/pipermail/buildroot/2021-April/308373.html

 > Packages like mkpimage where the source code is included in the Buildroot
 > tree, currently doesn't use an extract step (which also skips the patch
 > step), so they cannot be patched by a patch in BR2_GLOBAL_PATCH_DIR (or the
 > pkgdir), which is a bit confusing.

 > As a fix, add a simple extract step that copies the source file to the build
 > directory, so the patch step gets run as well.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2021.02.x, thanks.
diff mbox series

Patch

diff --git a/package/mkpimage/mkpimage.mk b/package/mkpimage/mkpimage.mk
index 8e08013f91..71500f00f3 100644
--- a/package/mkpimage/mkpimage.mk
+++ b/package/mkpimage/mkpimage.mk
@@ -9,9 +9,13 @@  HOST_MKPIMAGE_LICENSE = GPL-2.0
 # source included in the package
 # came from barebox's repository:
 # https://git.pengutronix.de/cgit/barebox/tree/scripts/socfpga_mkimage.c?id=55d29525146dcd280987dfd565bfd34f08858fb3
+define HOST_MKPIMAGE_EXTRACT_CMDS
+	cp $(HOST_MKPIMAGE_PKGDIR)/mkpimage.c $(@D)
+endef
+
 define HOST_MKPIMAGE_BUILD_CMDS
 	$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
-		package/mkpimage/mkpimage.c -o $(@D)/mkpimage
+		$(@D)/mkpimage.c -o $(@D)/mkpimage
 endef
 
 define HOST_MKPIMAGE_INSTALL_CMDS