diff mbox series

[20/25] package/python3-decorator: add _CPE_ID_VENDOR and _CPE_ID_PRODUCT

Message ID 20210420201146.42858-20-matthew.weber@rockwellcollins.com
State Accepted
Headers show
Series [01/25] package/automake: add _CPE_ID_VENDOR | expand

Commit Message

Matt Weber April 20, 2021, 8:11 p.m. UTC
cpe:2.3:a:python:decorator:* is a valid CPE identifier for this package:

 https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe:2.3:a:python:decorator

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
 package/python3-decorator/python3-decorator.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yann E. MORIN April 20, 2021, 8:56 p.m. UTC | #1
On 2021-04-20 15:11 -0500, Matt Weber spake thusly:
> cpe:2.3:a:python:decorator:* is a valid CPE identifier for this package:
> 
>  https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe:2.3:a:python:decorator
> 
> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
> ---
>  package/python3-decorator/python3-decorator.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/python3-decorator/python3-decorator.mk b/package/python3-decorator/python3-decorator.mk
> index c14f10fbf4..e6f940a95c 100644
> --- a/package/python3-decorator/python3-decorator.mk
> +++ b/package/python3-decorator/python3-decorator.mk
> @@ -11,6 +11,8 @@ PYTHON3_DECORATOR_SOURCE = decorator-$(PYTHON3_DECORATOR_VERSION).tar.gz
>  PYTHON3_DECORATOR_LICENSE = BSD-2-Clause
>  PYTHON3_DECORATOR_LICENSE_FILES = LICENSE.txt
>  PYTHON3_DECORATOR_SETUP_TYPE = setuptools
> +PYTHON3_DECORATOR_CPE_ID_VENDOR = python
> +PYTHON3_DECORATOR_CPE_ID_PRODUCT = decorator

At the top of the file, there's a comment:

    # Please keep in sync with package/python-decorator/python-decorator.mk

So, could you respin this one with both packages changed at once,
please?

Regards,
Yann E. MORIN.

>  HOST_PYTHON3_DECORATOR_NEEDS_HOST_PYTHON = python3
>  
>  $(eval $(host-python-package))
> -- 
> 2.17.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN April 20, 2021, 8:58 p.m. UTC | #2
Matthew, All,

On 2021-04-20 22:56 +0200, Yann E. MORIN spake thusly:
> On 2021-04-20 15:11 -0500, Matt Weber spake thusly:
> > cpe:2.3:a:python:decorator:* is a valid CPE identifier for this package:
> > 
> >  https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe:2.3:a:python:decorator
> > 
> > Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
> > ---
> >  package/python3-decorator/python3-decorator.mk | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/package/python3-decorator/python3-decorator.mk b/package/python3-decorator/python3-decorator.mk
> > index c14f10fbf4..e6f940a95c 100644
> > --- a/package/python3-decorator/python3-decorator.mk
> > +++ b/package/python3-decorator/python3-decorator.mk
> > @@ -11,6 +11,8 @@ PYTHON3_DECORATOR_SOURCE = decorator-$(PYTHON3_DECORATOR_VERSION).tar.gz
> >  PYTHON3_DECORATOR_LICENSE = BSD-2-Clause
> >  PYTHON3_DECORATOR_LICENSE_FILES = LICENSE.txt
> >  PYTHON3_DECORATOR_SETUP_TYPE = setuptools
> > +PYTHON3_DECORATOR_CPE_ID_VENDOR = python
> > +PYTHON3_DECORATOR_CPE_ID_PRODUCT = decorator
> 
> At the top of the file, there's a comment:
> 
>     # Please keep in sync with package/python-decorator/python-decorator.mk
> 
> So, could you respin this one with both packages changed at once,
> please?

Forget it, it's already there...

/me rubs his eyes...

Yes, it's already there. 

Sorry for the noise (but the commit could have stated that ;-) )...

Regards,
Yann E. MORIN.

> Regards,
> Yann E. MORIN.
> 
> >  HOST_PYTHON3_DECORATOR_NEEDS_HOST_PYTHON = python3
> >  
> >  $(eval $(host-python-package))
> > -- 
> > 2.17.1
> > 
> > _______________________________________________
> > buildroot mailing list
> > buildroot@busybox.net
> > http://lists.busybox.net/mailman/listinfo/buildroot
> 
> -- 
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/python3-decorator/python3-decorator.mk b/package/python3-decorator/python3-decorator.mk
index c14f10fbf4..e6f940a95c 100644
--- a/package/python3-decorator/python3-decorator.mk
+++ b/package/python3-decorator/python3-decorator.mk
@@ -11,6 +11,8 @@  PYTHON3_DECORATOR_SOURCE = decorator-$(PYTHON3_DECORATOR_VERSION).tar.gz
 PYTHON3_DECORATOR_LICENSE = BSD-2-Clause
 PYTHON3_DECORATOR_LICENSE_FILES = LICENSE.txt
 PYTHON3_DECORATOR_SETUP_TYPE = setuptools
+PYTHON3_DECORATOR_CPE_ID_VENDOR = python
+PYTHON3_DECORATOR_CPE_ID_PRODUCT = decorator
 HOST_PYTHON3_DECORATOR_NEEDS_HOST_PYTHON = python3
 
 $(eval $(host-python-package))