diff mbox series

[v1,1/3] package/postgis: disable protobuf support

Message ID 20210414201042.3685-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/3] package/postgis: disable protobuf support | expand

Commit Message

Peter Seiderer April 14, 2021, 8:10 p.m. UTC
- needs protobuf-c (not protobuf)
- protobuf-c configure tests are not cross-compile capable, even with

  ifeq ($(BR2_PACKAGE_PROTOBUF_C),y)
  POSTGIS_DEPENDENCIES += protobuf-c
  POSTGIS_CONF_OPTS += --with-protobuf
  POSTGIS_CONF_ENV += \
  	ac_cv_lib_protobuf_c_protobuf_c_message_init=yes \
  	ac_cv_lib_protobuf_c_protobuf_c_version=yes
  else
  POSTGIS_CONF_OPTS += --without-protobuf
  endif

  configure aborts with:

  checking for PROTOBUFC... yes
  checking protobuf-c/protobuf-c.h usability... yes
  checking protobuf-c/protobuf-c.h presence... yes
  checking for protobuf-c/protobuf-c.h... yes
  checking for protobuf_c_message_init in -lprotobuf-c... (cached) yes
  checking for protobuf_c_version in -lprotobuf-c... (cached) yes
  checking protobuf-c version... configure: error: in `.../build/postgis-3.1.1':
  configure: error: cannot run test program while cross compiling

Fixes:

  - http://autobuild.buildroot.net/results/8b95086b5e0876d0a4e41330446e767e4abd3729

  checking for PROTOBUFC... no
  libprotobuf-c not found in pkg-config
  checking protobuf-c/protobuf-c.h usability... no
  checking protobuf-c/protobuf-c.h presence... no
  checking for protobuf-c/protobuf-c.h... no
  configure: error: unable to find protobuf-c/protobuf-c.h using CPPFLAGS. You can disable MVT and Geobuf support using --without-protobuf

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/postgis/postgis.mk | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)

Comments

Maxim Kochetkov April 15, 2021, 4:30 a.m. UTC | #1
Reviewed-by: Maxim Kochetkov <fido_max@inbox.ru>

14.04.2021 23:10, Peter Seiderer пишет:
> - needs protobuf-c (not protobuf)
> - protobuf-c configure tests are not cross-compile capable, even with
> 
>    ifeq ($(BR2_PACKAGE_PROTOBUF_C),y)
>    POSTGIS_DEPENDENCIES += protobuf-c
>    POSTGIS_CONF_OPTS += --with-protobuf
>    POSTGIS_CONF_ENV += \
>    	ac_cv_lib_protobuf_c_protobuf_c_message_init=yes \
>    	ac_cv_lib_protobuf_c_protobuf_c_version=yes
>    else
>    POSTGIS_CONF_OPTS += --without-protobuf
>    endif
> 
>    configure aborts with:
> 
>    checking for PROTOBUFC... yes
>    checking protobuf-c/protobuf-c.h usability... yes
>    checking protobuf-c/protobuf-c.h presence... yes
>    checking for protobuf-c/protobuf-c.h... yes
>    checking for protobuf_c_message_init in -lprotobuf-c... (cached) yes
>    checking for protobuf_c_version in -lprotobuf-c... (cached) yes
>    checking protobuf-c version... configure: error: in `.../build/postgis-3.1.1':
>    configure: error: cannot run test program while cross compiling
> 
> Fixes:
> 
>    - http://autobuild.buildroot.net/results/8b95086b5e0876d0a4e41330446e767e4abd3729
> 
>    checking for PROTOBUFC... no
>    libprotobuf-c not found in pkg-config
>    checking protobuf-c/protobuf-c.h usability... no
>    checking protobuf-c/protobuf-c.h presence... no
>    checking for protobuf-c/protobuf-c.h... no
>    configure: error: unable to find protobuf-c/protobuf-c.h using CPPFLAGS. You can disable MVT and Geobuf support using --without-protobuf
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>   package/postgis/postgis.mk | 10 ++--------
>   1 file changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/package/postgis/postgis.mk b/package/postgis/postgis.mk
> index 1661f48ff2..92a9968993 100644
> --- a/package/postgis/postgis.mk
> +++ b/package/postgis/postgis.mk
> @@ -18,7 +18,8 @@ POSTGIS_DEPENDENCIES = postgresql libgeos proj libxml2
>   POSTGIS_CONF_OPTS += \
>   	--with-pgconfig=$(STAGING_DIR)/usr/bin/pg_config \
>   	--with-geosconfig=$(STAGING_DIR)/usr/bin/geos-config \
> -	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config
> +	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config \
> +	--without-protobuf
>   
>   ifeq ($(BR2_PACKAGE_LIBGDAL),y)
>   POSTGIS_DEPENDENCIES += libgdal
> @@ -27,11 +28,4 @@ else
>   POSTGIS_CONF_OPTS += --without-raster
>   endif
>   
> -ifeq ($(BR2_PACKAGE_PROTOBUF),y)
> -POSTGIS_DEPENDENCIES += protobuf
> -POSTGIS_CONF_OPTS += --with-protobuf
> -else
> -POSTGIS_CONF_OPTS += --without-protobuf
> -endif
> -
>   $(eval $(autotools-package))
>
Arnout Vandecappelle April 15, 2021, 7:17 p.m. UTC | #2
On 14/04/2021 22:10, Peter Seiderer wrote:
> - needs protobuf-c (not protobuf)
> - protobuf-c configure tests are not cross-compile capable, even with

 It's a pity to disable it rather than fix it, but I guess it should be fixed by
someone who cares.

 Series applied to master, thanks.

 Regards,
 Arnout

> 
>   ifeq ($(BR2_PACKAGE_PROTOBUF_C),y)
>   POSTGIS_DEPENDENCIES += protobuf-c
>   POSTGIS_CONF_OPTS += --with-protobuf
>   POSTGIS_CONF_ENV += \
>   	ac_cv_lib_protobuf_c_protobuf_c_message_init=yes \
>   	ac_cv_lib_protobuf_c_protobuf_c_version=yes
>   else
>   POSTGIS_CONF_OPTS += --without-protobuf
>   endif
> 
>   configure aborts with:
> 
>   checking for PROTOBUFC... yes
>   checking protobuf-c/protobuf-c.h usability... yes
>   checking protobuf-c/protobuf-c.h presence... yes
>   checking for protobuf-c/protobuf-c.h... yes
>   checking for protobuf_c_message_init in -lprotobuf-c... (cached) yes
>   checking for protobuf_c_version in -lprotobuf-c... (cached) yes
>   checking protobuf-c version... configure: error: in `.../build/postgis-3.1.1':
>   configure: error: cannot run test program while cross compiling
> 
> Fixes:
> 
>   - http://autobuild.buildroot.net/results/8b95086b5e0876d0a4e41330446e767e4abd3729
> 
>   checking for PROTOBUFC... no
>   libprotobuf-c not found in pkg-config
>   checking protobuf-c/protobuf-c.h usability... no
>   checking protobuf-c/protobuf-c.h presence... no
>   checking for protobuf-c/protobuf-c.h... no
>   configure: error: unable to find protobuf-c/protobuf-c.h using CPPFLAGS. You can disable MVT and Geobuf support using --without-protobuf
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
>  package/postgis/postgis.mk | 10 ++--------
>  1 file changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/package/postgis/postgis.mk b/package/postgis/postgis.mk
> index 1661f48ff2..92a9968993 100644
> --- a/package/postgis/postgis.mk
> +++ b/package/postgis/postgis.mk
> @@ -18,7 +18,8 @@ POSTGIS_DEPENDENCIES = postgresql libgeos proj libxml2
>  POSTGIS_CONF_OPTS += \
>  	--with-pgconfig=$(STAGING_DIR)/usr/bin/pg_config \
>  	--with-geosconfig=$(STAGING_DIR)/usr/bin/geos-config \
> -	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config
> +	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config \
> +	--without-protobuf
>  
>  ifeq ($(BR2_PACKAGE_LIBGDAL),y)
>  POSTGIS_DEPENDENCIES += libgdal
> @@ -27,11 +28,4 @@ else
>  POSTGIS_CONF_OPTS += --without-raster
>  endif
>  
> -ifeq ($(BR2_PACKAGE_PROTOBUF),y)
> -POSTGIS_DEPENDENCIES += protobuf
> -POSTGIS_CONF_OPTS += --with-protobuf
> -else
> -POSTGIS_CONF_OPTS += --without-protobuf
> -endif
> -
>  $(eval $(autotools-package))
>
diff mbox series

Patch

diff --git a/package/postgis/postgis.mk b/package/postgis/postgis.mk
index 1661f48ff2..92a9968993 100644
--- a/package/postgis/postgis.mk
+++ b/package/postgis/postgis.mk
@@ -18,7 +18,8 @@  POSTGIS_DEPENDENCIES = postgresql libgeos proj libxml2
 POSTGIS_CONF_OPTS += \
 	--with-pgconfig=$(STAGING_DIR)/usr/bin/pg_config \
 	--with-geosconfig=$(STAGING_DIR)/usr/bin/geos-config \
-	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config
+	--with-xml2config=$(STAGING_DIR)/usr/bin/xml2-config \
+	--without-protobuf
 
 ifeq ($(BR2_PACKAGE_LIBGDAL),y)
 POSTGIS_DEPENDENCIES += libgdal
@@ -27,11 +28,4 @@  else
 POSTGIS_CONF_OPTS += --without-raster
 endif
 
-ifeq ($(BR2_PACKAGE_PROTOBUF),y)
-POSTGIS_DEPENDENCIES += protobuf
-POSTGIS_CONF_OPTS += --with-protobuf
-else
-POSTGIS_CONF_OPTS += --without-protobuf
-endif
-
 $(eval $(autotools-package))