diff mbox series

[1/1] package/samba4: add required python deps for AD DC support

Message ID 20210404165823.954492-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/samba4: add required python deps for AD DC support | expand

Commit Message

Bernd Kuhls April 4, 2021, 4:58 p.m. UTC
Needed due to upstream commit:
https://gitlab.com/samba-team/samba/-/commit/2420b7c6d2038aca33759ca3a7d41240c5f19bf7

Fixes:
http://autobuild.buildroot.net/results/12a/12a74665a2349eacb28c3035bb36a4dce1d740d1/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/samba4/Config.in | 2 ++
 package/samba4/samba4.mk | 7 ++++++-
 2 files changed, 8 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni April 5, 2021, 9 a.m. UTC | #1
On Sun,  4 Apr 2021 18:58:23 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

>  ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
> -SAMBA4_DEPENDENCIES += jansson
> +SAMBA4_DEPENDENCIES += \
> +	jansson \
> +	host-python-dnspython \
> +	host-python-markdown \

I'm curious: why are the host packages needed? Is it because the
configuration stuff checks on the host that they are available, while
in fact they are only needed on the target ?

Thomas
Bernd Kuhls April 6, 2021, 7:52 a.m. UTC | #2
Am Mon, 05 Apr 2021 11:00:03 +0200 schrieb Thomas Petazzoni:

> On Sun,  4 Apr 2021 18:58:23 +0200 Bernd Kuhls
> <bernd.kuhls@t-online.de> wrote:
> 
>>  ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
>> -SAMBA4_DEPENDENCIES += jansson +SAMBA4_DEPENDENCIES += \ +	jansson \ 
+
>> host-python-dnspython \ +	host-python-markdown \
> 
> I'm curious: why are the host packages needed? Is it because the
> configuration stuff checks on the host that they are available, while in
> fact they are only needed on the target ?
> 
> Thomas

Hi Thomas,

yes, it seems to. The configure error could only be solved by also adding 
the host packages.

Regards, Bernd
Peter Korsgaard April 26, 2021, 1:26 p.m. UTC | #3
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Needed due to upstream commit:
 > https://gitlab.com/samba-team/samba/-/commit/2420b7c6d2038aca33759ca3a7d41240c5f19bf7

 > Fixes:
 > http://autobuild.buildroot.net/results/12a/12a74665a2349eacb28c3035bb36a4dce1d740d1/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 > ---
 >  package/samba4/Config.in | 2 ++
 >  package/samba4/samba4.mk | 7 ++++++-
 >  2 files changed, 8 insertions(+), 1 deletion(-)

 > diff --git a/package/samba4/Config.in b/package/samba4/Config.in
 > index a34eaa8088..e890313b71 100644
 > --- a/package/samba4/Config.in
 > +++ b/package/samba4/Config.in
 > @@ -32,6 +32,8 @@ config BR2_PACKAGE_SAMBA4_AD_DC
 >  	bool "AD DC"
 >  	depends on BR2_PACKAGE_PYTHON3
 >  	select BR2_PACKAGE_JANSSON
 > +	select BR2_PACKAGE_PYTHON_DNSPYTHON
 > +	select BR2_PACKAGE_PYTHON_MARKDOWN
 >  	help
 >  	  Enable Active Directory Domain Controller functionality.
 
 > diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
 > index 99c8af9ab2..ed38af020c 100644
 > --- a/package/samba4/samba4.mk
 > +++ b/package/samba4/samba4.mk
 > @@ -149,7 +149,12 @@ define SAMBA4_INSTALL_TARGET_CMDS
 >  endef
 
 >  ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
 > -SAMBA4_DEPENDENCIES += jansson
 > +SAMBA4_DEPENDENCIES += \
 > +	jansson \
 > +	host-python-dnspython \

How can this work? We don't currently have a host-python-dnspython
package.
Bernd Kuhls April 26, 2021, 4:57 p.m. UTC | #4
Am Mon, 26 Apr 2021 15:26:01 +0200 schrieb Peter Korsgaard:

> How can this work? We don't currently have a host-python-dnspython
> package.

Hi Peter,

it could not work because I forgot to send the patch adding host-python-
dnspython:

http://patchwork.ozlabs.org/project/buildroot/patch/
20210426165557.18477-1-bernd.kuhls@t-online.de/

Regards, Bernd
Peter Korsgaard April 26, 2021, 6:06 p.m. UTC | #5
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Needed due to upstream commit:
 > https://gitlab.com/samba-team/samba/-/commit/2420b7c6d2038aca33759ca3a7d41240c5f19bf7

 > Fixes:
 > http://autobuild.buildroot.net/results/12a/12a74665a2349eacb28c3035bb36a4dce1d740d1/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2021.02.x, thanks.
diff mbox series

Patch

diff --git a/package/samba4/Config.in b/package/samba4/Config.in
index a34eaa8088..e890313b71 100644
--- a/package/samba4/Config.in
+++ b/package/samba4/Config.in
@@ -32,6 +32,8 @@  config BR2_PACKAGE_SAMBA4_AD_DC
 	bool "AD DC"
 	depends on BR2_PACKAGE_PYTHON3
 	select BR2_PACKAGE_JANSSON
+	select BR2_PACKAGE_PYTHON_DNSPYTHON
+	select BR2_PACKAGE_PYTHON_MARKDOWN
 	help
 	  Enable Active Directory Domain Controller functionality.
 
diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
index 99c8af9ab2..ed38af020c 100644
--- a/package/samba4/samba4.mk
+++ b/package/samba4/samba4.mk
@@ -149,7 +149,12 @@  define SAMBA4_INSTALL_TARGET_CMDS
 endef
 
 ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
-SAMBA4_DEPENDENCIES += jansson
+SAMBA4_DEPENDENCIES += \
+	jansson \
+	host-python-dnspython \
+	host-python-markdown \
+	python-dnspython \
+	python-markdown
 else
 SAMBA4_CONF_OPTS += --without-ad-dc --without-json
 endif