diff mbox series

package/libxcrypt: --disable-werror to fix problem with sensitive compilers

Message ID 20210220173815.28154-1-guillaume.bressaix@gmail.com
State Accepted
Headers show
Series package/libxcrypt: --disable-werror to fix problem with sensitive compilers | expand

Commit Message

Guillaume Bres Feb. 20, 2021, 5:38 p.m. UTC
From: "Guillaume W. Bres" <guillaume.bressaix@gmail.com>

Fixes: http://autobuild.buildroot.net/results/e9a058a8c98daf197cd9d7ac632e0cb5707d524f

Some sensitive compilers may raise warnings that turn into errors.

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
---
 package/libxcrypt/libxcrypt.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Yann E. MORIN Feb. 20, 2021, 5:43 p.m. UTC | #1
Guillaume, All,

On 2021-02-20 18:38 +0100, guillaume.bressaix@gmail.com spake thusly:
> From: "Guillaume W. Bres" <guillaume.bressaix@gmail.com>
> 
> Fixes: http://autobuild.buildroot.net/results/e9a058a8c98daf197cd9d7ac632e0cb5707d524f
> 
> Some sensitive compilers may raise warnings that turn into errors.
> 
> Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>

Applied to next, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libxcrypt/libxcrypt.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/libxcrypt/libxcrypt.mk b/package/libxcrypt/libxcrypt.mk
> index 63132edd9d..ccbb1a282c 100644
> --- a/package/libxcrypt/libxcrypt.mk
> +++ b/package/libxcrypt/libxcrypt.mk
> @@ -11,4 +11,7 @@ LIBXCRYPT_LICENSE_FILES = LICENSING COPYING.LIB
>  LIBXCRYPT_INSTALL_STAGING = YES
>  LIBXCRYPT_AUTORECONF = YES
>  
> +# Some warnings turn into errors with some sensitive compilers
> +LIBXCRYPT_CONF_OPTS = --disable-werror
> +
>  $(eval $(autotools-package))
> -- 
> 2.20.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libxcrypt/libxcrypt.mk b/package/libxcrypt/libxcrypt.mk
index 63132edd9d..ccbb1a282c 100644
--- a/package/libxcrypt/libxcrypt.mk
+++ b/package/libxcrypt/libxcrypt.mk
@@ -11,4 +11,7 @@  LIBXCRYPT_LICENSE_FILES = LICENSING COPYING.LIB
 LIBXCRYPT_INSTALL_STAGING = YES
 LIBXCRYPT_AUTORECONF = YES
 
+# Some warnings turn into errors with some sensitive compilers
+LIBXCRYPT_CONF_OPTS = --disable-werror
+
 $(eval $(autotools-package))