diff mbox series

package/cegui: override first _CONF_OPTS instead of appending

Message ID 20210218175905.9837-1-b.bilas@grinn-global.com
State Accepted
Headers show
Series package/cegui: override first _CONF_OPTS instead of appending | expand

Commit Message

Bartosz Bilas Feb. 18, 2021, 5:59 p.m. UTC
During the package update, there was a mistake
and we appended the options to the first CONF_OPTS
variable instead of overriding it.
Fix that by removing an append-assignment.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/cegui/cegui.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Feb. 19, 2021, 9:48 p.m. UTC | #1
Bartosz, All,

On 2021-02-18 18:59 +0100, Bartosz Bilas spake thusly:
> During the package update, there was a mistake
> and we appended the options to the first CONF_OPTS
> variable instead of overriding it.
> Fix that by removing an append-assignment.
> 
> Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Applied to master, thanks, with the following tweaks;

  - reference the exact commit that introduce the issue
  - also move the first item to its own line

Regards,
Yann E. MORIN.

> ---
>  package/cegui/cegui.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/cegui/cegui.mk b/package/cegui/cegui.mk
> index 23919e0151..0596d6566b 100644
> --- a/package/cegui/cegui.mk
> +++ b/package/cegui/cegui.mk
> @@ -9,7 +9,7 @@ CEGUI_SITE = $(call github,cegui,cegui,v$(CEGUI_VERSION))
>  CEGUI_LICENSE = MIT
>  CEGUI_LICENSE_FILES = COPYING
>  CEGUI_INSTALL_STAGING = YES
> -CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
> +CEGUI_CONF_OPTS = -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
>  	-DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF \
>  	-DCEGUI_BUILD_RENDERER_OGRE=OFF
>  CEGUI_DEPENDENCIES = glm \
> -- 
> 2.30.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Feb. 27, 2021, 5:58 p.m. UTC | #2
>>>>> "Bartosz" == Bartosz Bilas <b.bilas@grinn-global.com> writes:

 > During the package update, there was a mistake
 > and we appended the options to the first CONF_OPTS
 > variable instead of overriding it.
 > Fix that by removing an append-assignment.

 > Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Committed to 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/cegui/cegui.mk b/package/cegui/cegui.mk
index 23919e0151..0596d6566b 100644
--- a/package/cegui/cegui.mk
+++ b/package/cegui/cegui.mk
@@ -9,7 +9,7 @@  CEGUI_SITE = $(call github,cegui,cegui,v$(CEGUI_VERSION))
 CEGUI_LICENSE = MIT
 CEGUI_LICENSE_FILES = COPYING
 CEGUI_INSTALL_STAGING = YES
-CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
+CEGUI_CONF_OPTS = -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
 	-DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF \
 	-DCEGUI_BUILD_RENDERER_OGRE=OFF
 CEGUI_DEPENDENCIES = glm \