diff mbox series

[4/4] package/collectd: add 'synproxy' option

Message ID 20210216135432.4830-5-patrickdepinguin@gmail.com
State Accepted
Headers show
Series [1/4] package/collectd: add 'infiniband' option | expand

Commit Message

Thomas De Schampheleire Feb. 16, 2021, 1:54 p.m. UTC
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

The synproxy plugin exists since 5.8.0 and is enabled by default in
collectd.

Add an option in Buildroot, disabled by default.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
 package/collectd/Config.in   | 5 +++++
 package/collectd/collectd.mk | 1 +
 2 files changed, 6 insertions(+)

Comments

Peter Korsgaard Feb. 16, 2021, 8:01 p.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 > The synproxy plugin exists since 5.8.0 and is enabled by default in
 > collectd.

 > Add an option in Buildroot, disabled by default.

 > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/collectd/Config.in b/package/collectd/Config.in
index 679285d997..82c24fdbc3 100644
--- a/package/collectd/Config.in
+++ b/package/collectd/Config.in
@@ -513,6 +513,11 @@  config BR2_PACKAGE_COLLECTD_SWAP
 	help
 	  Collects the amount of memory currently written to disk.
 
+config BR2_PACKAGE_COLLECTD_SYNPROXY
+	bool "synproxy"
+	help
+	  Synproxy stats plugin.
+
 config BR2_PACKAGE_COLLECTD_TABLE
 	bool "table"
 	help
diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index d57e6b8c1d..7db753b342 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -132,6 +132,7 @@  COLLECTD_CONF_OPTS += \
 	$(if $(BR2_PACKAGE_COLLECTD_SMART),--enable-smart,--disable-smart) \
 	$(if $(BR2_PACKAGE_COLLECTD_SNMP),--enable-snmp,--disable-snmp) \
 	$(if $(BR2_PACKAGE_COLLECTD_SWAP),--enable-swap,--disable-swap) \
+	$(if $(BR2_PACKAGE_COLLECTD_SYNPROXY),--enable-synproxy,--disable-synproxy) \
 	$(if $(BR2_PACKAGE_COLLECTD_SYSLOG),--enable-syslog,--disable-syslog) \
 	$(if $(BR2_PACKAGE_COLLECTD_TABLE),--enable-table,--disable-table) \
 	$(if $(BR2_PACKAGE_COLLECTD_TAIL),--enable-tail,--disable-tail) \