diff mbox series

[1/1] package/x11r7/xapp_xload: disable gettext detection when not needed

Message ID 20201204205052.1404782-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/x11r7/xapp_xload: disable gettext detection when not needed | expand

Commit Message

Bernd Kuhls Dec. 4, 2020, 8:50 p.m. UTC
Patch originates from FreeBSD:
https://lists.freebsd.org/pipermail/freebsd-x11/2015-July/016528.html
https://svnweb.freebsd.org/ports/head/x11/libXpm/Makefile?r1=384234&r2=391122&pathrev=391122

Fixes:
http://autobuild.buildroot.net/results/2ad/2ad27875ce5c16a111d54d452eb395257e9b5e2b/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
xlib_libXpm was fixed the same way:
http://patchwork.ozlabs.org/project/buildroot/patch/20180107175626.19944-1-bernd.kuhls@t-online.de/

 package/x11r7/xapp_xload/xapp_xload.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Yann E. MORIN Jan. 2, 2021, 9:46 p.m. UTC | #1
Bernd, All,

On 2020-12-04 21:50 +0100, Bernd Kuhls spake thusly:
> Patch originates from FreeBSD:
> https://lists.freebsd.org/pipermail/freebsd-x11/2015-July/016528.html
> https://svnweb.freebsd.org/ports/head/x11/libXpm/Makefile?r1=384234&r2=391122&pathrev=391122
> 
> Fixes:
> http://autobuild.buildroot.net/results/2ad/2ad27875ce5c16a111d54d452eb395257e9b5e2b/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Applied to master, thanks.

> ---
> xlib_libXpm was fixed the same way:
> http://patchwork.ozlabs.org/project/buildroot/patch/20180107175626.19944-1-bernd.kuhls@t-online.de/

I have added a reference to that commit in the commit log, thanks!

Regards,
Yann E. MORIN.

>  package/x11r7/xapp_xload/xapp_xload.mk | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/x11r7/xapp_xload/xapp_xload.mk b/package/x11r7/xapp_xload/xapp_xload.mk
> index 4bb21ecf0b..9f491ccdc6 100644
> --- a/package/x11r7/xapp_xload/xapp_xload.mk
> +++ b/package/x11r7/xapp_xload/xapp_xload.mk
> @@ -18,4 +18,8 @@ ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
>  XAPP_XLOAD_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -DRLOADSTUB"
>  endif
>  
> +ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
> +XAPP_XLOAD_CONF_ENV += ac_cv_search_gettext=no
> +endif
> +
>  $(eval $(autotools-package))
> -- 
> 2.29.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Jan. 5, 2021, 10:05 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Patch originates from FreeBSD:
 > https://lists.freebsd.org/pipermail/freebsd-x11/2015-July/016528.html
 > https://svnweb.freebsd.org/ports/head/x11/libXpm/Makefile?r1=384234&r2=391122&pathrev=391122

 > Fixes:
 > http://autobuild.buildroot.net/results/2ad/2ad27875ce5c16a111d54d452eb395257e9b5e2b/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 > ---
 > xlib_libXpm was fixed the same way:
 > http://patchwork.ozlabs.org/project/buildroot/patch/20180107175626.19944-1-bernd.kuhls@t-online.de/

Committed to 2020.02.x and 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/x11r7/xapp_xload/xapp_xload.mk b/package/x11r7/xapp_xload/xapp_xload.mk
index 4bb21ecf0b..9f491ccdc6 100644
--- a/package/x11r7/xapp_xload/xapp_xload.mk
+++ b/package/x11r7/xapp_xload/xapp_xload.mk
@@ -18,4 +18,8 @@  ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
 XAPP_XLOAD_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -DRLOADSTUB"
 endif
 
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
+XAPP_XLOAD_CONF_ENV += ac_cv_search_gettext=no
+endif
+
 $(eval $(autotools-package))