diff mbox series

[v1,2/2] package/webkitgtk: add optional systemd dependency

Message ID 20201109231356.32230-2-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/2] package/webkitgtk: fix opengl configure option | expand

Commit Message

Peter Seiderer Nov. 9, 2020, 11:13 p.m. UTC
- systemd support/USE_SYSTEMD option was added since 2.30.0,
  so add an optional dependency

Fixes:

  -- Could NOT find Systemd (missing: Systemd_LIBRARY Systemd_INCLUDE_DIR)
  CMake Error at Source/cmake/OptionsGTK.cmake:425 (message):
    libsystemd is needed for USE_SYSTEMD

Reported-by: C Larbi <pkl2000us@gmail.com>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/webkitgtk/webkitgtk.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Adrian Perez de Castro Nov. 10, 2020, 8:32 a.m. UTC | #1
Hi Peter,

This is a good one as well, thanks!

On Tue, 10 Nov 2020 00:13:56 +0100 Peter Seiderer <ps.report@gmx.net> wrote:
> - systemd support/USE_SYSTEMD option was added since 2.30.0,
>   so add an optional dependency
> 
> Fixes:
> 
>   -- Could NOT find Systemd (missing: Systemd_LIBRARY Systemd_INCLUDE_DIR)
>   CMake Error at Source/cmake/OptionsGTK.cmake:425 (message):
>     libsystemd is needed for USE_SYSTEMD
> 
> Reported-by: C Larbi <pkl2000us@gmail.com>
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Acked-by: Adrian Perez de Castro <aperez@igalia.com>

> ---
>  package/webkitgtk/webkitgtk.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
> index 5209eeed2d..84078f8b9a 100644
> --- a/package/webkitgtk/webkitgtk.mk
> +++ b/package/webkitgtk/webkitgtk.mk
> @@ -104,6 +104,13 @@ else
>  WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
>  endif
>  
> +ifeq ($(BR2_INIT_SYSTEMD),y)
> +WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=ON
> +WEBKITGTK_DEPENDENCIES += systemd
> +else
> +WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=OFF
> +endif
> +
>  # JIT is not supported for MIPS r6, but the WebKit build system does not
>  # have a check for these processors. The same goes for ARMv5 and ARMv6.
>  # Disable JIT forcibly here and use the CLoop interpreter instead.
> -- 
> 2.29.2
>
Peter Korsgaard Nov. 10, 2020, 8:25 p.m. UTC | #2
>>>>> "Peter" == Peter Seiderer <ps.report@gmx.net> writes:

 > - systemd support/USE_SYSTEMD option was added since 2.30.0,
 >   so add an optional dependency

 > Fixes:

 >   -- Could NOT find Systemd (missing: Systemd_LIBRARY Systemd_INCLUDE_DIR)
 >   CMake Error at Source/cmake/OptionsGTK.cmake:425 (message):
 >     libsystemd is needed for USE_SYSTEMD

 > Reported-by: C Larbi <pkl2000us@gmail.com>
 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
index 5209eeed2d..84078f8b9a 100644
--- a/package/webkitgtk/webkitgtk.mk
+++ b/package/webkitgtk/webkitgtk.mk
@@ -104,6 +104,13 @@  else
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=ON
+WEBKITGTK_DEPENDENCIES += systemd
+else
+WEBKITGTK_CONF_OPTS += -DUSE_SYSTEMD=OFF
+endif
+
 # JIT is not supported for MIPS r6, but the WebKit build system does not
 # have a check for these processors. The same goes for ARMv5 and ARMv6.
 # Disable JIT forcibly here and use the CLoop interpreter instead.