diff mbox series

[1/2] package/webkitgtk: fix build with ENABLE_C_LOOP=ON

Message ID 20201020155311.3493430-2-aperez@igalia.com
State Accepted
Headers show
Series package/webkitgtk: build fixes for CPUs which need CLoop | expand

Commit Message

Adrian Perez de Castro Oct. 20, 2020, 3:53 p.m. UTC
The ENABLE_C_LOOP option conflicts with ENABLE_SAMPLING_PROFILER, so
the WebKit CMake build system will emit an error when both are enabled
at the same time. To avoid hitting that situation, explicitly disable
ENABLE_SAMPLING_PROFILER as needed.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 package/webkitgtk/webkitgtk.mk | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 29, 2020, 7:01 p.m. UTC | #1
>>>>> "Adrian" == Adrian Perez de Castro <aperez@igalia.com> writes:

 > The ENABLE_C_LOOP option conflicts with ENABLE_SAMPLING_PROFILER, so
 > the WebKit CMake build system will emit an error when both are enabled
 > at the same time. To avoid hitting that situation, explicitly disable
 > ENABLE_SAMPLING_PROFILER as needed.

 > Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

Committed to 2020.02.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
index 5293d2d0ff..7fab924cc8 100644
--- a/package/webkitgtk/webkitgtk.mk
+++ b/package/webkitgtk/webkitgtk.mk
@@ -108,9 +108,12 @@  endif
 # have a check for these processors. Disable JIT forcibly here and use
 # the CLoop interpreter instead.
 #
+# Also, we have to disable the sampling profiler, which does NOT work
+# with ENABLE_C_LOOP.
+#
 # Upstream bug: https://bugs.webkit.org/show_bug.cgi?id=191258
 ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
-WEBKITGTK_CONF_OPTS += -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON
+WEBKITGTK_CONF_OPTS += -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON -DENABLE_SAMPLING_PROFILER=OFF
 endif
 
 $(eval $(cmake-package))