diff mbox series

[v2,3/4] package/busybox: explicitly state binutil paths

Message ID 20201017221743.160029-3-nolange79@gmail.com
State Accepted
Headers show
Series [v2,1/4] package/Makefile.in: use gcc wrappers for binutils tools | expand

Commit Message

Norbert Lange Oct. 17, 2020, 10:17 p.m. UTC
Pass paths to ar, nm, ranlib binaries. This allows linker-plugins
to be used.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/busybox/busybox.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Yann E. MORIN Jan. 9, 2022, 3:09 p.m. UTC | #1
Norbet, All,

On 2020-10-18 00:17 +0200, Norbert Lange spake thusly:
> Pass paths to ar, nm, ranlib binaries. This allows linker-plugins
> to be used.

I have expanded/reworded the commit log to explain why this is needed
specifically for busybox.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/busybox/busybox.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
> index 01f7331221..221b8adf59 100644
> --- a/package/busybox/busybox.mk
> +++ b/package/busybox/busybox.mk
> @@ -94,6 +94,9 @@ BUSYBOX_MAKE_ENV += \
>  endif
>  
>  BUSYBOX_MAKE_OPTS = \
> +	AR="$(TARGET_AR)" \
> +	NM="$(TARGET_NM)" \
> +	RANLIB="$(TARGET_RANLIB)" \
>  	CC="$(TARGET_CC)" \
>  	ARCH=$(KERNEL_ARCH) \
>  	PREFIX="$(TARGET_DIR)" \
> -- 
> 2.28.0
diff mbox series

Patch

diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 01f7331221..221b8adf59 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -94,6 +94,9 @@  BUSYBOX_MAKE_ENV += \
 endif
 
 BUSYBOX_MAKE_OPTS = \
+	AR="$(TARGET_AR)" \
+	NM="$(TARGET_NM)" \
+	RANLIB="$(TARGET_RANLIB)" \
 	CC="$(TARGET_CC)" \
 	ARCH=$(KERNEL_ARCH) \
 	PREFIX="$(TARGET_DIR)" \