diff mbox series

[1/1] package/libblockdev: fs needs mount

Message ID 20201015160622.846446-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/libblockdev: fs needs mount | expand

Commit Message

Fabrice Fontaine Oct. 15, 2020, 4:06 p.m. UTC
Fixes:
 - http://autobuild.buildroot.org/results/1f83436a84046da753a2ebf2aac7c0f0cc188fe0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libblockdev/Config.in      | 2 ++
 package/libblockdev/libblockdev.mk | 2 +-
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 15, 2020, 6:12 p.m. UTC | #1
On Thu, 15 Oct 2020 18:06:22 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fixes:
>  - http://autobuild.buildroot.org/results/1f83436a84046da753a2ebf2aac7c0f0cc188fe0
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libblockdev/Config.in      | 2 ++
>  package/libblockdev/libblockdev.mk | 2 +-
>  2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libblockdev/Config.in b/package/libblockdev/Config.in
> index 3c501b7871..5836fa6cf2 100644
> --- a/package/libblockdev/Config.in
> +++ b/package/libblockdev/Config.in
> @@ -28,6 +28,8 @@ config BR2_PACKAGE_LIBBLOCKDEV_CRYPTO
>  config BR2_PACKAGE_LIBBLOCKDEV_FS
>  	bool "filesystem"
>  	depends on BR2_ENABLE_LOCALE # parted
> +	select BR2_PACKAGE_UTIL_LINUX
> +	select BR2_PACKAGE_UTIL_LINUX_MOUNT

Are you sure it's not BR2_PACKAGE_UTIL_LINUX_LIBMOUNT that is needed? I
guess libblockdev needs libmount, not the mount/umount programs. Could
you check this ?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/libblockdev/Config.in b/package/libblockdev/Config.in
index 3c501b7871..5836fa6cf2 100644
--- a/package/libblockdev/Config.in
+++ b/package/libblockdev/Config.in
@@ -28,6 +28,8 @@  config BR2_PACKAGE_LIBBLOCKDEV_CRYPTO
 config BR2_PACKAGE_LIBBLOCKDEV_FS
 	bool "filesystem"
 	depends on BR2_ENABLE_LOCALE # parted
+	select BR2_PACKAGE_UTIL_LINUX
+	select BR2_PACKAGE_UTIL_LINUX_MOUNT
 	select BR2_PACKAGE_PARTED
 
 comment "filesystem plugin needs a toolchain w/ locale"
diff --git a/package/libblockdev/libblockdev.mk b/package/libblockdev/libblockdev.mk
index 1b094555d2..a38912514c 100644
--- a/package/libblockdev/libblockdev.mk
+++ b/package/libblockdev/libblockdev.mk
@@ -39,7 +39,7 @@  LIBBLOCKDEV_CONF_OPTS += --without-crypto
 endif
 
 ifeq ($(BR2_PACKAGE_LIBBLOCKDEV_FS),y)
-LIBBLOCKDEV_DEPENDENCIES += parted
+LIBBLOCKDEV_DEPENDENCIES += parted util-linux
 LIBBLOCKDEV_CONF_OPTS += --with-fs
 else
 LIBBLOCKDEV_CONF_OPTS += --without-fs