diff mbox series

[3/3] package/freetype: add brotli optional dependency

Message ID 20201001202626.1354496-3-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/3] package/freetype: drop libpng workaround | expand

Commit Message

Fabrice Fontaine Oct. 1, 2020, 8:26 p.m. UTC
brotli is an optional dependency (enabled by default) since version
2.10.2 and
https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=9443a1bc3e6cfa315db976ff80f6c5e91b12b387

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/freetype/freetype.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Peter Korsgaard Oct. 3, 2020, 6:49 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > brotli is an optional dependency (enabled by default) since version
 > 2.10.2 and
 > https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=9443a1bc3e6cfa315db976ff80f6c5e91b12b387

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/freetype/freetype.mk b/package/freetype/freetype.mk
index b0aba78c51..e6463c30b6 100644
--- a/package/freetype/freetype.mk
+++ b/package/freetype/freetype.mk
@@ -16,6 +16,7 @@  FREETYPE_CONFIG_SCRIPTS = freetype-config
 
 HOST_FREETYPE_DEPENDENCIES = host-pkgconf
 HOST_FREETYPE_CONF_OPTS = \
+	--without-brotli \
 	--without-bzip2 \
 	--without-harfbuzz \
 	--without-png \
@@ -32,6 +33,13 @@  else
 FREETYPE_CONF_OPTS += --without-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_BROTLI),y)
+FREETYPE_DEPENDENCIES += brotli
+FREETYPE_CONF_OPTS += --with-brotli
+else
+FREETYPE_CONF_OPTS += --without-brotli
+endif
+
 ifeq ($(BR2_PACKAGE_BZIP2),y)
 FREETYPE_DEPENDENCIES += bzip2
 FREETYPE_CONF_OPTS += --with-bzip2