diff mbox series

[2/3] package/freetype: add harfbuzz optional dependency

Message ID 20201001202626.1354496-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/3] package/freetype: drop libpng workaround | expand

Commit Message

Fabrice Fontaine Oct. 1, 2020, 8:26 p.m. UTC
harfbuzz is an optional dependency (enabled by default) since version
2.5.3 and
https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=86026a47b345a8c254dd5e6be77bf116737cdafb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/freetype/freetype.mk | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 3, 2020, 6:50 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > harfbuzz is an optional dependency (enabled by default) since version
 > 2.5.3 and
 > https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=86026a47b345a8c254dd5e6be77bf116737cdafb

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.02.x, 2020.05.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/freetype/freetype.mk b/package/freetype/freetype.mk
index 428531ed08..b0aba78c51 100644
--- a/package/freetype/freetype.mk
+++ b/package/freetype/freetype.mk
@@ -15,7 +15,11 @@  FREETYPE_DEPENDENCIES = host-pkgconf
 FREETYPE_CONFIG_SCRIPTS = freetype-config
 
 HOST_FREETYPE_DEPENDENCIES = host-pkgconf
-HOST_FREETYPE_CONF_OPTS = --without-zlib --without-bzip2 --without-png
+HOST_FREETYPE_CONF_OPTS = \
+	--without-bzip2 \
+	--without-harfbuzz \
+	--without-png \
+	--without-zlib
 
 # since 2.9.1 needed for freetype-config install
 FREETYPE_CONF_OPTS += --enable-freetype-config
@@ -35,6 +39,13 @@  else
 FREETYPE_CONF_OPTS += --without-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
+FREETYPE_DEPENDENCIES += harfbuzz
+FREETYPE_CONF_OPTS += --with-harbuzz
+else
+FREETYPE_CONF_OPTS += --without-harfbuzz
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 FREETYPE_DEPENDENCIES += libpng
 FREETYPE_CONF_OPTS += --with-png