diff mbox series

[1/1] package/elfutils: fix host build

Message ID 20201001052550.106879-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/elfutils: fix host build | expand

Commit Message

Fabrice Fontaine Oct. 1, 2020, 5:25 a.m. UTC
Commit 52c5c6050c5359288ca48c85024aebd169fab258 disabled debuginfod on
target but not on host resulting in the following build failure:

configure: error: dependencies not found, use --disable-libdebuginfod to disable or --enable-libdebuginfod=dummy to build a (bootstrap) dummy library.

Fixes:
 - http://autobuild.buildroot.org/results/97713c7e281313826067af559337832f22c3cb09

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/elfutils/elfutils.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Oct. 1, 2020, 8:53 a.m. UTC | #1
On Thu,  1 Oct 2020 07:25:50 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit 52c5c6050c5359288ca48c85024aebd169fab258 disabled debuginfod on
> target but not on host resulting in the following build failure:
> 
> configure: error: dependencies not found, use --disable-libdebuginfod to disable or --enable-libdebuginfod=dummy to build a (bootstrap) dummy library.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/97713c7e281313826067af559337832f22c3cb09
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/elfutils/elfutils.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index 3615a16cd0..28f86c2fab 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -50,6 +50,7 @@  endif
 
 # disable for now, needs "distro" support
 ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
+HOST_ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
 
 ELFUTILS_CONF_ENV += \
 	LDFLAGS="$(ELFUTILS_LDFLAGS)"