diff mbox series

package/qt5: allow to use imx-gpu-viv as GBM provider

Message ID 20200929082017.19485-1-gary.bisson@boundarydevices.com
State Accepted
Headers show
Series package/qt5: allow to use imx-gpu-viv as GBM provider | expand

Commit Message

Gary Bisson Sept. 29, 2020, 8:20 a.m. UTC
Needed in order to use eglfs_kms platform backend.

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
---
 package/qt5/qt5base/qt5base.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Peter Seiderer Sept. 29, 2020, 7:09 p.m. UTC | #1
Hello Gary,

On Tue, 29 Sep 2020 10:20:17 +0200, Gary Bisson <gary.bisson@boundarydevices.com> wrote:

> Needed in order to use eglfs_kms platform backend.
>
> Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
> ---
>  package/qt5/qt5base/qt5base.mk | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
> index 359a380075..1232a03778 100644
> --- a/package/qt5/qt5base/qt5base.mk
> +++ b/package/qt5/qt5base/qt5base.mk
> @@ -79,6 +79,9 @@ QT5BASE_DEPENDENCIES += gcnano-binaries
>  else ifeq ($(BR2_PACKAGE_TI_SGX_LIBGBM),y)
>  QT5BASE_CONFIGURE_OPTS += -gbm
>  QT5BASE_DEPENDENCIES += ti-sgx-libgbm
> +else ifeq ($(BR2_PACKAGE_IMX_GPU_VIV),y)
> +QT5BASE_CONFIGURE_OPTS += -gbm
> +QT5BASE_DEPENDENCIES += imx-gpu-viv
>  else
>  QT5BASE_CONFIGURE_OPTS += -no-gbm
>  endif

Reviewed-by: Peter Seiderer <ps.report@gmx.net>

Regards,
Peter
Thomas Petazzoni Sept. 30, 2020, 7:48 p.m. UTC | #2
On Tue, 29 Sep 2020 10:20:17 +0200
Gary Bisson <gary.bisson@boundarydevices.com> wrote:

> Needed in order to use eglfs_kms platform backend.
> 
> Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
> ---
>  package/qt5/qt5base/qt5base.mk | 3 +++
>  1 file changed, 3 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Oct. 2, 2020, 7:48 p.m. UTC | #3
>>>>> "Gary" == Gary Bisson <gary.bisson@boundarydevices.com> writes:

 > Needed in order to use eglfs_kms platform backend.
 > Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>

Committed to 2020.02.x, 2020.05.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 359a380075..1232a03778 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -79,6 +79,9 @@  QT5BASE_DEPENDENCIES += gcnano-binaries
 else ifeq ($(BR2_PACKAGE_TI_SGX_LIBGBM),y)
 QT5BASE_CONFIGURE_OPTS += -gbm
 QT5BASE_DEPENDENCIES += ti-sgx-libgbm
+else ifeq ($(BR2_PACKAGE_IMX_GPU_VIV),y)
+QT5BASE_CONFIGURE_OPTS += -gbm
+QT5BASE_DEPENDENCIES += imx-gpu-viv
 else
 QT5BASE_CONFIGURE_OPTS += -no-gbm
 endif