diff mbox series

package/gcc: drop leftovers from PowerPC conditional patching

Message ID 20200924102219.3443175-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/gcc: drop leftovers from PowerPC conditional patching | expand

Commit Message

Thomas Petazzoni Sept. 24, 2020, 10:22 a.m. UTC
We used to have a conditional patch applied on PowerPC soft-float, but
this logic was dropped in commit
0c82f3f63563c4d4d7e034d0e9e4ceb766d92322 ("package/gcc: remove powerpc
conditional patching logic"). However, we still have some related
leftovers in the calculation of the hashes for ccache, which can now
be dropped.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Romain Naour <romain.naour@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
---
 package/gcc/gcc.mk | 5 -----
 1 file changed, 5 deletions(-)

Comments

Romain Naour Sept. 30, 2020, 9:05 p.m. UTC | #1
Hi Thomas,

Le 24/09/2020 à 12:22, Thomas Petazzoni a écrit :
> We used to have a conditional patch applied on PowerPC soft-float, but
> this logic was dropped in commit
> 0c82f3f63563c4d4d7e034d0e9e4ceb766d92322 ("package/gcc: remove powerpc
> conditional patching logic"). However, we still have some related
> leftovers in the calculation of the hashes for ccache, which can now
> be dropped.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Romain Naour <romain.naour@gmail.com>
> Cc: Arnout Vandecappelle <arnout@mind.be>

Acked-by: Romain Naour <romain.naour@gmail.com>

Best regards,
Romain

> ---
>  package/gcc/gcc.mk | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/package/gcc/gcc.mk b/package/gcc/gcc.mk
> index d9c4b4ef83..cc1dbbcf3a 100644
> --- a/package/gcc/gcc.mk
> +++ b/package/gcc/gcc.mk
> @@ -279,11 +279,6 @@ HOST_GCC_COMMON_CCACHE_HASH_FILES += \
>  ifeq ($(BR2_xtensa),y)
>  HOST_GCC_COMMON_CCACHE_HASH_FILES += $(ARCH_XTENSA_OVERLAY_TAR)
>  endif
> -ifeq ($(ARCH),powerpc)
> -ifneq ($(BR2_SOFT_FLOAT),)
> -HOST_GCC_COMMON_CCACHE_HASH_FILES += package/gcc/$(GCC_VERSION)/1000-powerpc-link-with-math-lib.patch.conditional
> -endif
> -endif
>  
>  # _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
>  # and a reference to the Buildroot git revision (BR2_VERSION_FULL),
>
Thomas Petazzoni Oct. 1, 2020, 8:58 a.m. UTC | #2
On Thu, 24 Sep 2020 12:22:18 +0200
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> We used to have a conditional patch applied on PowerPC soft-float, but
> this logic was dropped in commit
> 0c82f3f63563c4d4d7e034d0e9e4ceb766d92322 ("package/gcc: remove powerpc
> conditional patching logic"). However, we still have some related
> leftovers in the calculation of the hashes for ccache, which can now
> be dropped.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Romain Naour <romain.naour@gmail.com>
> Cc: Arnout Vandecappelle <arnout@mind.be>
> ---
>  package/gcc/gcc.mk | 5 -----
>  1 file changed, 5 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Oct. 3, 2020, 6:16 a.m. UTC | #3
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > We used to have a conditional patch applied on PowerPC soft-float, but
 > this logic was dropped in commit
 > 0c82f3f63563c4d4d7e034d0e9e4ceb766d92322 ("package/gcc: remove powerpc
 > conditional patching logic"). However, we still have some related
 > leftovers in the calculation of the hashes for ccache, which can now
 > be dropped.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Romain Naour <romain.naour@gmail.com>
 > Cc: Arnout Vandecappelle <arnout@mind.be>

Committed to 2020.05.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/gcc/gcc.mk b/package/gcc/gcc.mk
index d9c4b4ef83..cc1dbbcf3a 100644
--- a/package/gcc/gcc.mk
+++ b/package/gcc/gcc.mk
@@ -279,11 +279,6 @@  HOST_GCC_COMMON_CCACHE_HASH_FILES += \
 ifeq ($(BR2_xtensa),y)
 HOST_GCC_COMMON_CCACHE_HASH_FILES += $(ARCH_XTENSA_OVERLAY_TAR)
 endif
-ifeq ($(ARCH),powerpc)
-ifneq ($(BR2_SOFT_FLOAT),)
-HOST_GCC_COMMON_CCACHE_HASH_FILES += package/gcc/$(GCC_VERSION)/1000-powerpc-link-with-math-lib.patch.conditional
-endif
-endif
 
 # _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
 # and a reference to the Buildroot git revision (BR2_VERSION_FULL),