diff mbox series

[RFC,v1,13/13] package/gst-omx: bump version to 1.18.0 and convert to meson

Message ID 20200916194933.24921-13-ps.report@gmx.net
State Changes Requested
Headers show
Series [RFC,v1,01/13] package/gst1-interpipe: bump version to 94dea52 (1.1.2) | expand

Commit Message

Peter Seiderer Sept. 16, 2020, 7:49 p.m. UTC
- change home page url to https

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Notes:
 - droped the version downgrade for the bellagio case (no meson
   options available), maybe needs extra testing...
---
 package/gstreamer1/gst-omx/Config.in    |  2 +-
 package/gstreamer1/gst-omx/gst-omx.hash |  6 +++---
 package/gstreamer1/gst-omx/gst-omx.mk   | 24 ++++++++++--------------
 3 files changed, 14 insertions(+), 18 deletions(-)

Comments

Thomas Petazzoni Sept. 23, 2020, 8:31 p.m. UTC | #1
On Wed, 16 Sep 2020 21:49:33 +0200
Peter Seiderer <ps.report@gmx.net> wrote:

> - change home page url to https
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
> Notes:
>  - droped the version downgrade for the bellagio case (no meson
>    options available), maybe needs extra testing...

I think this really needs to be looked at, or we dropped bellagio,
which hasn't seen any update since 2011. It has never been clear to me
what bellagio is exactly: isn't the OpenMAX API supposed to be like
OpenGL, i.e provide some HW-platform specific implementations ?

Thomas
Peter Seiderer Sept. 24, 2020, 8:17 p.m. UTC | #2
Hello Thomas,

On Wed, 23 Sep 2020 22:31:59 +0200, Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> On Wed, 16 Sep 2020 21:49:33 +0200
> Peter Seiderer <ps.report@gmx.net> wrote:
>
> > - change home page url to https
> >
> > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> > ---
> > Notes:
> >  - droped the version downgrade for the bellagio case (no meson
> >    options available), maybe needs extra testing...
>
> I think this really needs to be looked at, or we dropped bellagio,
> which hasn't seen any update since 2011. It has never been clear to me
> what bellagio is exactly: isn't the OpenMAX API supposed to be like
> OpenGL, i.e provide some HW-platform specific implementations ?

Dropping bellagio (in case no one raises one hand to keep support for it)
is fine with me (but I am no OpenMAX user)...

The other specific targets are rpi (already handled), tizonia and
zynqultrascaleplus...

Regards,
Peter

>
> Thomas
diff mbox series

Patch

diff --git a/package/gstreamer1/gst-omx/Config.in b/package/gstreamer1/gst-omx/Config.in
index d2e477648b..efe3d211d6 100644
--- a/package/gstreamer1/gst-omx/Config.in
+++ b/package/gstreamer1/gst-omx/Config.in
@@ -5,7 +5,7 @@  config BR2_PACKAGE_GST_OMX
 	help
 	  GStreamer plug-in to use OpenMAX API.
 
-	  http://cgit.freedesktop.org/gstreamer/gst-omx
+	  https://cgit.freedesktop.org/gstreamer/gst-omx
 
 comment "gst-omx requires a OpenMAX implementation"
 	depends on !BR2_PACKAGE_HAS_LIBOPENMAX
diff --git a/package/gstreamer1/gst-omx/gst-omx.hash b/package/gstreamer1/gst-omx/gst-omx.hash
index 85487f3491..9cd1b49a33 100644
--- a/package/gstreamer1/gst-omx/gst-omx.hash
+++ b/package/gstreamer1/gst-omx/gst-omx.hash
@@ -1,3 +1,3 @@ 
-# From https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-1.16.2.tar.xz.sha256sum
-sha256 11ed411a2eba75610d72331eeb14ff05e2df28f4fd05cb69225a88bec6d27439 gst-omx-1.16.2.tar.xz
-sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
+# From https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-1.18.0.tar.xz.sha256sum
+sha256  302c65e04578991364f7605e04cfb54dfd75268d51080d35f221ee1a8b341fad  gst-omx-1.18.0.tar.xz
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
diff --git a/package/gstreamer1/gst-omx/gst-omx.mk b/package/gstreamer1/gst-omx/gst-omx.mk
index 5ed9e3ce2c..c60997a315 100644
--- a/package/gstreamer1/gst-omx/gst-omx.mk
+++ b/package/gstreamer1/gst-omx/gst-omx.mk
@@ -4,33 +4,29 @@ 
 #
 ################################################################################
 
-GST_OMX_VERSION = 1.16.2
+GST_OMX_VERSION = 1.18.0
 GST_OMX_SOURCE = gst-omx-$(GST_OMX_VERSION).tar.xz
 GST_OMX_SITE = https://gstreamer.freedesktop.org/src/gst-omx
 
 GST_OMX_LICENSE = LGPL-2.1
 GST_OMX_LICENSE_FILES = COPYING
 
+GST_OMX_CONF_OPTS = \
+	-Dexamples=disabled \
+	-Dtests=disabled \
+	-Dtools=disabled \
+	-Ddoc=disabled
+
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 GST_OMX_VARIANT = rpi
-GST_OMX_CONF_ENV = \
-	CFLAGS="$(TARGET_CFLAGS) \
-		-I$(STAGING_DIR)/usr/include/IL \
-		-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
-		-I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux"
+GST_OMX_CONF_OPTS += -Dheader_path=$(STAGING_DIR)/usr/include/IL
 else ifeq ($(BR2_PACKAGE_BELLAGIO),y)
 GST_OMX_VARIANT = bellagio
-GST_OMX_CONF_ENV = \
-	CFLAGS="$(TARGET_CFLAGS) \
-		-DOMX_VERSION_MAJOR=1 \
-		-DOMX_VERSION_MINOR=1 \
-		-DOMX_VERSION_REVISION=2 \
-		-DOMX_VERSION_STEP=0"
 else
 GST_OMX_VARIANT = generic
 endif
 
-GST_OMX_CONF_OPTS += --with-omx-target=$(GST_OMX_VARIANT)
+GST_OMX_CONF_OPTS += -Dtarget=$(GST_OMX_VARIANT)
 
 GST_OMX_DEPENDENCIES = gstreamer1 gst1-plugins-base libopenmax
 
@@ -42,4 +38,4 @@  endef
 
 GST_OMX_POST_PATCH_HOOKS += GST_OMX_FIXUP_CONFIG_PATHS
 
-$(eval $(autotools-package))
+$(eval $(meson-package))