diff mbox series

[1/1] package/dhcpdump: fix build without pod2man

Message ID 20200914204239.3456222-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/dhcpdump: fix build without pod2man | expand

Commit Message

Fabrice Fontaine Sept. 14, 2020, 8:42 p.m. UTC
Use dhcpdump target to avoid building dhcpdump.8 as it will raise the
following build failure if pod2man is not available:

pod2man --section 8 \
	--date "23 June 2008" \
	--name "DHCPDUMP" \
	--center "User Contributed Software" \
	dhcpdump.pod dhcpdump.8
/bin/sh: pod2man: command not found
make[1]: *** [Makefile:11: dhcpdump.8] Error 127

Fixes:
 - http://autobuild.buildroot.org/results/db3be149ec71de8376f685a6a9f027191d9bccc9

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dhcpdump/dhcpdump.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Sept. 19, 2020, 7:14 p.m. UTC | #1
On Mon, 14 Sep 2020 22:42:39 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Use dhcpdump target to avoid building dhcpdump.8 as it will raise the
> following build failure if pod2man is not available:
> 
> pod2man --section 8 \
> 	--date "23 June 2008" \
> 	--name "DHCPDUMP" \
> 	--center "User Contributed Software" \
> 	dhcpdump.pod dhcpdump.8
> /bin/sh: pod2man: command not found
> make[1]: *** [Makefile:11: dhcpdump.8] Error 127
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/db3be149ec71de8376f685a6a9f027191d9bccc9
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/dhcpdump/dhcpdump.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 28, 2020, 9:21 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Use dhcpdump target to avoid building dhcpdump.8 as it will raise the
 > following build failure if pod2man is not available:

 > pod2man --section 8 \
 > 	--date "23 June 2008" \
 > 	--name "DHCPDUMP" \
 > 	--center "User Contributed Software" \
 > 	dhcpdump.pod dhcpdump.8
 > /bin/sh: pod2man: command not found
 > make[1]: *** [Makefile:11: dhcpdump.8] Error 127

 > Fixes:
 >  - http://autobuild.buildroot.org/results/db3be149ec71de8376f685a6a9f027191d9bccc9

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.02.x, 2020.05.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/dhcpdump/dhcpdump.mk b/package/dhcpdump/dhcpdump.mk
index 2413812880..ec9571c0af 100644
--- a/package/dhcpdump/dhcpdump.mk
+++ b/package/dhcpdump/dhcpdump.mk
@@ -20,7 +20,7 @@  DHCPDUMP_CFLAGS = $(TARGET_CFLAGS) -DHAVE_STRSEP
 
 define DHCPDUMP_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) CC="$(TARGET_CC) $(DHCPDUMP_CFLAGS) \
-		-D_GNU_SOURCE" LIBS="$(DHCPDUMP_LIBS)"
+		-D_GNU_SOURCE" LIBS="$(DHCPDUMP_LIBS)" dhcpdump
 endef
 
 define DHCPDUMP_INSTALL_TARGET_CMDS