diff mbox series

[1/1] package/boost: bump to version 1.74.0

Message ID 20200909061618.2053427-1-fido_max@inbox.ru
State Changes Requested
Headers show
Series [1/1] package/boost: bump to version 1.74.0 | expand

Commit Message

Maxim Kochetkov Sept. 9, 2020, 6:16 a.m. UTC
bimap broken with C++20 GCC 10 due to allocator changes
https://github.com/boostorg/bimap/issues/23

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
---
 package/boost/boost.hash | 4 ++--
 package/boost/boost.mk   | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Sept. 9, 2020, 7:09 a.m. UTC | #1
Hello Maxim,

Thanks for your contribution.

On Wed,  9 Sep 2020 09:16:18 +0300
Maxim Kochetkov via buildroot <buildroot@busybox.net> wrote:

> bimap broken with C++20 GCC 10 due to allocator changes
> https://github.com/boostorg/bimap/issues/23

I'm not sure what this sentence means. Does this means that this new
version of Boost doesn't build with gcc 10 ? Or that it fixes issues
with gcc 10 ?

Thanks!

Thomas
Michael Nosthoff Sept. 9, 2020, 7:45 a.m. UTC | #2
Hi Maxim,

I was just about to submit this bump myself. So I can confirm that it
compiles fine.
Some remarks below.

On 09.09.2020 08:16, Maxim Kochetkov via buildroot wrote:
> bimap broken with C++20 GCC 10 due to allocator changes
> https://github.com/boostorg/bimap/issues/23

From the commits linked in the issue I take this issue was fixed in the
1.74.0.beta1.

> Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
> ---
>  package/boost/boost.hash | 4 ++--
>  package/boost/boost.mk   | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)


The 0002 patch has a slight offset change.


diff --git a/package/boost/0002-fenv.patch b/package/boost/0002-fenv.patch
index 95c769aea2..9dc7848c93 100644
--- a/package/boost/0002-fenv.patch
+++ b/package/boost/0002-fenv.patch
@@ -18,7 +18,7 @@ Index: b/boost/config/platform/linux.hpp
 ===================================================================
 --- a/boost/config/platform/linux.hpp
 +++ b/boost/config/platform/linux.hpp
-@@ -47,6 +47,16 @@
+@@ -48,6 +48,16 @@
  #endif

  //

could you add that?


Regards,
Michael
diff mbox series

Patch

diff --git a/package/boost/boost.hash b/package/boost/boost.hash
index c94699aa67..d11232f5a9 100644
--- a/package/boost/boost.hash
+++ b/package/boost/boost.hash
@@ -1,5 +1,5 @@ 
-# From https://www.boost.org/users/history/version_1_73_0.html
-sha256  4eb3b8d442b426dc35346235c8733b5ae35ba431690e38c6a8263dce9fcbb402  boost_1_73_0.tar.bz2
+# From https://www.boost.org/users/history/version_1_74_0.html
+sha256  83bfc1507731a0906e387fc28b7ef5417d591429e51e788417fe9ff025e116b1  boost_1_74_0.tar.bz2
 
 # Locally computed
 sha256  c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566  LICENSE_1_0.txt
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 323802488d..82fe42d6b2 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BOOST_VERSION = 1.73.0
+BOOST_VERSION = 1.74.0
 BOOST_SOURCE = boost_$(subst .,_,$(BOOST_VERSION)).tar.bz2
 BOOST_SITE = https://dl.bintray.com/boostorg/release/$(BOOST_VERSION)/source
 BOOST_INSTALL_STAGING = YES