diff mbox series

[2/2] package/systemd: disable audit for host package

Message ID 20200829135941.1862456-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/systemd: disable cryptsetup for host package | expand

Commit Message

Fabrice Fontaine Aug. 29, 2020, 1:59 p.m. UTC
Disable audit for host package to avoid getting the following error if
it is found on host:

[84/662] Generating audit_type-list.txt with a meson_exe.py custom command
In file included from <command-line>:32:
./../src/basic/missing_audit.h:7:10: fatal error: libaudit.h: No such file or directory
    7 | #include <libaudit.h>
      |          ^~~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/67782c225c08387c1bbcbea9eee3ca12bc6577cd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/systemd/systemd.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Aug. 29, 2020, 4:35 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable audit for host package to avoid getting the following error if
 > it is found on host:

 > [84/662] Generating audit_type-list.txt with a meson_exe.py custom command
 > In file included from <command-line>:32:
 > ./../src/basic/missing_audit.h:7:10: fatal error: libaudit.h: No such file or directory
 >     7 | #include <libaudit.h>
 >       |          ^~~~~~~~~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/67782c225c08387c1bbcbea9eee3ca12bc6577cd

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 115ccbda06..81fa2bd0f0 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -700,7 +700,8 @@  HOST_SYSTEMD_CONF_OPTS = \
 	-Dxdg-autostart=false \
 	-Dkernel-install=false \
 	-Dsystemd-analyze=false \
-	-Dlibcryptsetup=false
+	-Dlibcryptsetup=false \
+	-Daudit=false
 
 HOST_SYSTEMD_DEPENDENCIES = \
 	$(BR2_COREUTILS_HOST_DEPENDENCY) \