diff mbox series

[1/1] package/elixir: fix host-erlang dependency

Message ID 20200820103034.11094-1-frank.vanbever@essensium.com
State Accepted
Headers show
Series [1/1] package/elixir: fix host-erlang dependency | expand

Commit Message

Frank Vanbever Aug. 20, 2020, 10:30 a.m. UTC
Make it explicit that host-elixir depends on host-erlang. This fixes the
build in cases where BR2_PER_PACKAGE_DIRECTORIES is set.

Fixes:
- http://autobuild.buildroot.net/results/a3a37eb724ca5689f8e83c9b2af04d07afa80315/

Signed-off-by: Frank Vanbever <frank.vanbever@essensium.com>
---
 package/elixir/elixir.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Aug. 20, 2020, 10:01 p.m. UTC | #1
On Thu, 20 Aug 2020 12:30:34 +0200
Frank Vanbever <frank.vanbever@essensium.com> wrote:

> Make it explicit that host-elixir depends on host-erlang. This fixes the
> build in cases where BR2_PER_PACKAGE_DIRECTORIES is set.
> 
> Fixes:
> - http://autobuild.buildroot.net/results/a3a37eb724ca5689f8e83c9b2af04d07afa80315/
> 
> Signed-off-by: Frank Vanbever <frank.vanbever@essensium.com>
> ---
>  package/elixir/elixir.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 28, 2020, 4:54 p.m. UTC | #2
>>>>> "Frank" == Frank Vanbever <frank.vanbever@essensium.com> writes:

 > Make it explicit that host-elixir depends on host-erlang. This fixes the
 > build in cases where BR2_PER_PACKAGE_DIRECTORIES is set.

 > Fixes:
 > - http://autobuild.buildroot.net/results/a3a37eb724ca5689f8e83c9b2af04d07afa80315/

 > Signed-off-by: Frank Vanbever <frank.vanbever@essensium.com>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/elixir/elixir.mk b/package/elixir/elixir.mk
index 7a545d43b0..6d935516f4 100644
--- a/package/elixir/elixir.mk
+++ b/package/elixir/elixir.mk
@@ -8,7 +8,7 @@  ELIXIR_VERSION = 1.9.4
 ELIXIR_SITE = $(call github,elixir-lang,elixir,v$(ELIXIR_VERSION))
 ELIXIR_LICENSE = Apache-2.0
 ELIXIR_LICENSE_FILES = LICENSE
-ELIXIR_DEPENDENCIES = host-erlang
+HOST_ELIXIR_DEPENDENCIES = host-erlang
 
 define HOST_ELIXIR_BUILD_CMDS
 	$(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) compile